1145 Hashing - Average Search Time (25分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 10
​4
​​ . Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 10
​5
​​ .

Output Specification:
For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:
4 5 4
10 6 4 15 11
11 4 15 2
Sample Output:
15 cannot be inserted.
2.8

又是平方探测法解决hash冲突,这次真的记住了,我这里写的麻烦了,其实step从0开始即可,一直到mSzie-1,判断(x+pow(step,2))%msize是否有数字,如果没有就插入。
最后search时,如果找到当前位为0,也可以直接break不用往下找了

//先将n个数字插入散列表,如何插入要先求出散列表长度(素数),冲突问题用正向平方探测解决,然后是查询问题
#include<iostream>
#include<cmath>
#include<vector>
#include<cstdio>
using namespace std;
bool isPrime(int x){
    if(x <= 1) return false;
    int Sqrt = sqrt(x);
    for(int i = 2; i <= Sqrt; i++){
        if(x % i == 0) return false;
    }
    return true;
}
int main(){
    int mSize,n,m,x;
    cin>>mSize>>n>>m;
    while(!isPrime(mSize)) mSize++;
    vector<int> hashTable(mSize,0);
    for(int i = 0; i < n; i++){
        cin>>x;
        bool flag = false;
        if(hashTable[x%mSize] == 0){
            hashTable[x%mSize] = x;
            continue;
        }
        for(int step = 1; step < mSize; step++){
            if(hashTable[(x + step*step)%mSize] == 0){
                hashTable[(x + step*step)%mSize] = x;
                flag = true;
                break;
            }
        }
        if(flag == false) cout<<x<<" cannot be inserted.\n";
    }
    double ans = 0.0;
    for(int i = 0; i < m; i++){
        cin>>x;
        for(int step = 0; step <= mSize; step++){
            ans++;
            if(hashTable[(x+step*step)%mSize] == x || hashTable[(x+step*step)%mSize] == 0) break;
        }
    }
    printf("%.1f",ans/m);
    return 0;
}

平方探测法来构建hash表和检测是否有这个值,(x+step*step)%mSize,step从0开始。
构建哈希表时,step从0到mSize-1,检测key时,step从0到mSize!!

//插入一串不同数字的序列进散列表
//先根据n个数字构建散列表,再看散列表里是否找得出这m个数字
//(x+step^2)%msize,step小于msize
//查找时如果查找的第一位是0,那就不用找下去了,因为根本没这个数字
#include<iostream>
#include<cmath>
#include<vector>
using namespace std;
bool isPrime(int x){
    if(x <= 1) return false;
    int Sqrt = (int)sqrt(x);
    for(int i = 2; i <= Sqrt; i++){
        if(x%i==0) return false;
    }
    return true;
}
int main(){
    int mSize,n,m,x;
    cin>>mSize>>n>>m;
    while(!isPrime(mSize)) mSize++;
    vector<int> hashTable(mSize,0);
    for(int i = 0; i < n; i++){
        cin>>x;
        bool flag = false;
        for(int step = 0; step < mSize; step++){
            if(hashTable[(x+step*step)%mSize] == 0){
                hashTable[(x+step*step)%mSize] = x;
                flag = true;
                break;
            }
        }
        if(flag == false) cout<<x<<" cannot be inserted.\n";
    }
    double sum = 0.0;
    for(int i = 0; i < m; i++){
        cin>>x;
        for(int step = 0; step <= mSize; step++){
            sum++;
            if(hashTable[(x+step*step) % mSize] == x) break;
            if(hashTable[(x+step*step) % mSize] == 0) break;
        }
    }
    printf("%.1f",sum*1.0/m);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值