bzoj 1648: [Usaco2006 Dec]Cow Picnic 奶牛野餐(暴力DFS)

1648: [Usaco2006 Dec]Cow Picnic 奶牛野餐

Time Limit: 5 Sec   Memory Limit: 64 MB
Submit: 774   Solved: 480
[ Submit][ Status][ Discuss]

Description

The cows are having a picnic! Each of Farmer John's K (1 <= K <= 100) cows is grazing in one of N (1 <= N <= 1,000) pastures, conveniently numbered 1...N. The pastures are connected by M (1 <= M <= 10,000) one-way paths (no path connects a pasture to itself). The cows want to gather in the same pasture for their picnic, but (because of the one-way paths) some cows may only be able to get to some pastures. Help the cows out by figuring out how many pastures are reachable by all cows, and hence are possible picnic locations.

  K(1≤K≤100)只奶牛分散在N(1≤N≤1000)个牧场.现在她们要集中起来进餐.牧场之间有M(1≤M≤10000)条有向路连接,而且不存在起点和终点相同的有向路.她们进餐的地点必须是所有奶牛都可到达的地方.那么,有多少这样的牧场呢?

Input

* Line 1: Three space-separated integers, respectively: K, N, and M * Lines 2..K+1: Line i+1 contains a single integer (1..N) which is the number of the pasture in which cow i is grazing. * Lines K+2..M+K+1: Each line contains two space-separated integers, respectively A and B (both 1..N and A != B), representing a one-way path from pasture A to pasture B.

 1行输入KNM.接下来K行,每行一个整数表示一只奶牛所在的牧场编号.接下来M行,每行两个整数,表示一条有向路的起点和终点

Output

* Line 1: The single integer that is the number of pastures that are reachable by all cows via the one-way paths.

    所有奶牛都可到达的牧场个数

Sample Input

2 4 4
2
3
1 2
1 4
2 3
3 4

Sample Output

2


暴力每头牛所有能到的点然后统计

闲着无聊试了下,这题没有重边但是有自环,所以若是

①用邻接矩阵:复杂度O(n²k)

②用邻接表:复杂度O((n+m)k)

③邻接矩阵后转邻接表:复杂度O(n²+nk)

其中第三种莫名最快


#include<stdio.h>
#include<vector>
#include<string.h>
using namespace std;
vector<int> G[1005];
int cow[105], sum[1005], vis[1005], road[1005][1005];
void Sech(int u)
{
	int i, v;
	vis[u] = 1, sum[u]++;
	for(i=0;i<G[u].size();i++)
	{
		v = G[u][i];
		if(vis[v]==0)
			Sech(v);
	}
}
int main(void)
{
	int ans, k, n, i, j, x, y, m;
	scanf("%d%d%d", &k, &n, &m);
	for(i=1;i<=k;i++)
		scanf("%d", &cow[i]);
	for(i=1;i<=m;i++)
	{
		scanf("%d%d", &x, &y);
		road[x][y] = 1;
	}
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=n;j++)
		{
			if(road[i][j])
				G[i].push_back(j);
		}
	}
	for(i=1;i<=k;i++)
	{
		memset(vis, 0, sizeof(vis));
		Sech(cow[i]);
	}
	ans = 0;
	for(i=1;i<=n;i++)
	{
		if(sum[i]==k)
			ans++;
	}
	printf("%d\n", ans);
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值