bzoj 1649: [Usaco2006 Dec]Cow Roller Coaster(DP)

1649: [Usaco2006 Dec]Cow Roller Coaster

Time Limit: 5 Sec   Memory Limit: 64 MB
Submit: 710   Solved: 358
[ Submit][ Status][ Discuss]

Description

The cows are building a roller coaster! They want your help to design as fun a roller coaster as possible, while keeping to the budget. The roller coaster will be built on a long linear stretch of land of length L (1 <= L <= 1,000). The roller coaster comprises a collection of some of the N (1 <= N <= 10,000) different interchangable components. Each component i has a fixed length Wi (1 <= Wi <= L). Due to varying terrain, each component i can be only built starting at location Xi (0 <= Xi <= L-Wi). The cows want to string together various roller coaster components starting at 0 and ending at L so that the end of each component (except the last) is the start of the next component. Each component i has a "fun rating" Fi (1 <= Fi <= 1,000,000) and a cost Ci (1 <= Ci <= 1000). The total fun of the roller coster is the sum of the fun from each component used; the total cost is likewise the sum of the costs of each component used. The cows' total budget is B (1 <= B <= 1000). Help the cows determine the most fun roller coaster that they can build with their budget.

奶牛们正打算造一条过山车轨道.她们希望你帮忙,找出最有趣,但又符合预算的方案.  过山车的轨道由若干钢轨首尾相连,由x=0处一直延伸到X=L(1≤L≤1000)处.现有N(1≤N≤10000)根钢轨,每根钢轨的起点Xi(0≤Xi≤L- Wi),长度wi(l≤Wi≤L),有趣指数Fi(1≤Fi≤1000000),成本Ci(l≤Ci≤1000)均己知.请确定一种最优方案,使得选用的钢轨的有趣指数之和最大,同时成本之和不超过B(1≤B≤1000).

Input

* Line 1: Three space-separated integers: L, N and B.

 * Lines 2..N+1: Line i+1 contains four space-separated integers, respectively: Xi, Wi, Fi, and Ci.

    第1行输入L,N,B,接下来N行,每行四个整数Xi,wi,Fi,Ci.

Output

* Line 1: A single integer that is the maximum fun value that a roller-coaster can have while staying within the budget and meeting all the other constraints. If it is not possible to build a roller-coaster within budget, output -1.

Sample Input

5 6 10
0 2 20 6
2 3 5 6
0 1 2 1
1 1 1 3
1 2 5 4
3 2 10 2

Sample Output

17


dp[i][j]表示前i米都铺完且费用为j的最大价值

第二维类似于01背包


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define LL long long
typedef struct Res
{
	int x, y;
	int cost, val;
	bool operator < (const Res &b) const
	{
		if(y<b.y)
			return 1;
		return 0;
	}
}Res;
Res s[10005];
LL dp[1005][1005];
int main(void)
{
	LL ans;
	int L, n, V, i, j, p;
	scanf("%d%d%d", &L, &n, &V);
	for(i=1;i<=n;i++)
	{
		scanf("%d%d%d%d", &s[i].x, &s[i].y, &s[i].val, &s[i].cost);
		s[i].y = s[i].x+s[i].y;
	}
	sort(s+1, s+n+1);
	memset(dp, -1, sizeof(dp));
	dp[0][0] = 0;
	p = 1;
	for(i=1;i<=L;i++)
	{
		while(s[p].y==i && p<=n)
		{
			for(j=V;j>=s[p].cost;j--)
			{
				if(dp[s[p].x][j-s[p].cost]==-1)
					continue;
				dp[i][j] = max(dp[i][j], dp[s[p].x][j-s[p].cost]+s[p].val);
			}
			p++;
		}
	}
	ans = -1;
	for(i=0;i<=V;i++)
	{
		if(dp[L][i]==-1)
			continue;
		ans = max(ans, dp[L][i]);
	}
	printf("%lld\n", ans);
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值