bzoj 1653: [Usaco2006 Feb]Backward Digit Sums(全排列)

1653: [Usaco2006 Feb]Backward Digit Sums

Time Limit: 5 Sec   Memory Limit: 64 MB
Submit: 502   Solved: 348
[ Submit][ Status][ Discuss]

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 3 1 2 4 4 3 6 7 9 16 Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. Write a program to help FJ play the game and keep up with the cows.

Input

* Line 1: Two space-separated integers: N and the final sum.

Output

* Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4


题意:有n个数,这n个数一定是1到n的全排列,进行n-1操作,每次都将a[i] += a[i+1],并把最后一个数丢掉,最后下来一定只剩一个数,如果这个数是m那么说明原先的n个数是个好序列。给出n和m,求出字典序最小的好序列


暴力全排列,然后暴力检测最后的值是否为m

可以用C++自带的next_permutation()函数

功能:如果存在下一个排列,就返回1并自动调整排列方式,如果不存在下一个排列,返回0

#include<stdio.h>
#include<algorithm>
using namespace std;
int main(void)
{
	int n, m, i, j, a[15], b[15];
	scanf("%d%d", &n, &m);
	for(i=1;i<=n;i++)
		a[i] = i;
	do
	{
		for(i=1;i<=n;i++)
			b[i] = a[i];
		for(i=1;i<=n-1;i++)
		{
			for(j=1;j<=n-i;j++)
				b[j] += b[j+1];
		}
		if(b[1]==m)
		{
			printf("%d", a[1]);
			for(i=2;i<=n;i++)
				printf(" %d", a[i]);
			printf("\n");
			break;
		}
	}while(next_permutation(a+1, a+n+1));
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值