3392: [Usaco2005 Feb]Part Acquisition 交易
Time Limit: 5 Sec Memory Limit: 128 MBSubmit: 191 Solved: 96
[ Submit][ Status][ Discuss]
Description
奶牛们接到了寻找一种新型挤奶机的任务,为此它们准备依次经过N(1≤N≤50000)颗行
星,在行星上进行交易.
为了方便,奶牛们已经给可能出现的K(1≤K≤1000)种货物进行了由1到K的标号.由于这
些行星都不是十分发达.没有流通的货币,所以在每个市场里都只能用固定的一种货物去换取另
一种货物.
奶牛们带着一种上好的饲料从地球出发,希望进行最少的交易,最终得到所需要的机器.饲
料的标号为1,所需要的机器的标号为K.如果任务无法完成,输出-1.
Input
第1行是两个数字N和K.
第2到N+1行,每行是两个数字Ai和Bi,表示第i颗行星愿意提供Ai为得到Bi.
Output
第1行输出最小交换次数
Sample Input
6 5
1 3
3 2
2 3
3 1
2 5
5 4
Sample Output
4
k个点,n条有向边,每条边长度都为1,求出1到k的最短路
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<vector>
#include<queue>
using namespace std;
vector<int> G[1005];
queue<int> q;
int dp[1005];
int main(void)
{
int x, y, n, m, i;
scanf("%d%d", &m, &n);
for(i=1;i<=m;i++)
{
scanf("%d%d", &x, &y);
G[x].push_back(y);
}
memset(dp, 62, sizeof(dp));
dp[1] = 1;
q.push(1);
while(q.empty()==0)
{
x = q.front();
q.pop();
for(i=0;i<G[x].size();i++)
{
y = G[x][i];
if(dp[x]+1<dp[y])
{
dp[y] = dp[x]+1;
q.push(y);
}
}
}
if(dp[n]>=1000000)
printf("-1\n");
else
printf("%d\n", dp[n]);
}