bzoj 2987: Earthquake(类欧几里得)

 

2987: Earthquake

Time Limit: 10 Sec  Memory Limit: 128 MB
Submit: 238  Solved: 134
[Submit][Status][Discuss]

Description

给定a,b,c,求满足方程Ax+By<=C的非负整数解

A,B<=10^9.C<=Min(A,B)*10^9

Input

Output

Sample Input

3 4 13

Sample Output

12

 

裸题,不过这是个贴着纵坐标轴的三角形,需要转换一下

具体看代码

 

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<map>
#include<string>
#include<math.h>
#include<queue>
#include<stack>
#include<iostream>
using namespace std;
#define LL long long
#define mod 1000000007
LL F(LL a, LL b, LL c, LL n)
{
	LL sum;
	if(a==0)
		return n*(b/c);
	if(b>=c || a>=c)
	{
		sum = (1+n)*n/2;
		return F(a%c, b%c, c, n)+sum*(a/c)+(n+1)*(b/c);
	}
	sum = (n*a+b)/c;
	return n*sum-F(c, c-b-1, a, sum-1);
}
int main(void)
{
	LL a, b, c;
	scanf("%lld%lld%lld", &a, &b, &c);
	printf("%lld\n", c/a+1+F(a, c%a, b, c/a));
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值