Find them, Catch them POJ - 1703

Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 46665 Accepted: 14367

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source

[Submit]   [Go Back]   [Status]   [Discuss]


Link: http://poj.org/problem?id=1703


题意:有两个团伙,给出两种操作:

    A X Y:询问 X Y 是否为同伙 ;

            D X Y:明确指出X Y为不同伙 ;


思路:典型的并查集思想,但指令给出的是不同伙(根节点不同),将两个团伙分成两个集,但接收到D指令时仍              然使用Combine()合并,使用+n区别开 ;


AC Code:

#include<cstdio>
using namespace std;

const int maxn=500000+50;
int fa[maxn],rank[maxn];

void init(int n){
    for(int i=1;i<=n;i++){
        fa[i]=i;
        rank[i]=0;
    }
}

int find(int x){
    return fa[x]==x?x:fa[x]=find(fa[x]);
}

void myunion(int a,int b){
    a=find(a); b=find(b);
    if(a==b) return ;
    if(rank[a]>rank[b]) fa[b]=a;
    else{
        fa[a]=b;
        if(rank[a]==rank[b]) ++rank[b];
    }

}

bool issame(int a,int b){
    return find(a)==find(b);

}

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        int n,m;
        scanf("%d%d",&n,&m);
        init(n*2);
        while(m--){
            char str[5];
            int a,b;
            scanf("%s%d%d",str,&a,&b);
            //printf("%s %d %d\n",str,a,b);
            if(str[0]=='D'){
                myunion(a,b+n);
                myunion(a+n,b);
            }
            else{
                if(issame(a,b)) printf("In the same gang.\n");
                else if(issame(a+n,b)) printf("In different gangs.\n");
                else printf("Not sure yet.\n");
            }
        }
    }
    return 0;

}


























  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值