POJ 3159 Candies 差分约束-SPFA栈实现

Candies
Time Limit: 1500MS Memory Limit: 131072K
Total Submissions: 33931 Accepted: 9528

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers A, B and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.

Source

[Submit]   [Go Back]   [Status]   [Discuss]


题意:

给n个人派糖果,给出m组数据,每组数据包含A,B,C  三个数,
意思是A的糖果数比B少的个数不多于C,即B - A<= c ;
最后求n 比 1 最多多多少糖果;


学习了一下差分约束,顺便学了一下栈版本的SPFA

①:对于差分不等式,a - b <= c ,建一条 b 到 a 的权值为 c 的边,求的是最短路,得到的是最大值
②:对于不等式 a - b >= c ,建一条 b 到 a 的权值为 c 的边,求的是最长路,得到的是最小值
③:存在负环的话是无解
④:求不出最短路(dist[ ]没有得到更新)的话是任意解


AC Code:

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <string>
#include <queue>
#include <vector>
#include <stack>
#include <iostream>
#include <algorithm>

using namespace std;

const int MAXN = 31000;
const int MAXE = 151000;
const int INF = 0x3f3f3f3f;

struct node {
    int v,w,next;
} edge[MAXE] ;

int Head[MAXN];
int Dis[MAXN];
bool vis[MAXN];
int n,m,top;

void AddEdge(int u,int v,int w) {
    edge[top].v = v;
    edge[top].w = w;
    edge[top].next = Head[u];
    Head[u] = top++;
}

void SPFA(int s) {
    stack<int> Q;
    memset(Dis,INF,sizeof(Dis));
    memset(vis,false,sizeof(vis));
    Dis[s] = 0 ; vis[s]=true;
    Q.push(s);
    while(!Q.empty()) {
        int u = Q.top(); Q.pop();
        for(int i = Head[u]; i!=-1; i = edge[i].next) {
            int v = edge[i].v;
            if(Dis[v]>Dis[u]+edge[i].w) {
                Dis[v] = Dis[u]+edge[i].w;
                if(!vis[v]) {
                    vis[v]=true;
                    Q.push(v);
                }
            }
        }
        vis[u] = false;
    }
}

int main() {
    int u,v,w;
    while(~scanf("%d %d",&n,&m)) {
        memset(Head,-1,sizeof(Head));
        top = 0;
        for(int i=1; i<=m; i++) {
            scanf("%d %d %d",&u,&v,&w);
            AddEdge(u,v,w);
        }
        SPFA(1);
        printf("%d\n",Dis[n]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值