Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0
题意: 求最长公共子序列长度
思路:经典的DP序列题,dp[i][j]为字符串1的前i个字符与字符串2的前j个字符的最长公共序列长度,状态方程:
if(s1[i-1]==s2[j-1]) dp[i][j]=dp[i-1][j-1]+1 //当对于字符相同时,当前dp=上一个dp+1;
else dp[i][j]=max(dp[i-1][j],dp[i][j-1]); //当字符不相同时,当前dp=上一个状态的两个dp的最大值
#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;
const int manx=1e4+5;
int dp[manx][manx];
int main()
{
string s1,s2;
while(cin>>s1>>s2)
{
int l1=s1.size(),l2=s2.size();
for(int i=1;i<=l1;i++)
{
for(int j=1;j<=l2;j++)
{
if(s1[i-1]==s2[j-1])
dp[i][j]=dp[i-1][j-1]+1;
else dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
}
}
cout<<dp[l1][l2]<<endl;
memset(dp,0,sizeof(dp));
}
return 0;
}