Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.
My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.
What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.
What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
Input
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
Sample Input
3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2
Sample Output
25.1327 3.1416 50.2655
分析:利用二分法进行求解问题 由于这题的精度问题,所以PI的定义时建议用的是原来的本意,另外还要考虑一下那个eps的精度确定的问题 应该在1e-5应该就能过;
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const double PI=acos(-1.0);
const double eps=1e-6;
int main()
{
int n,t,f,i,r,p;
cin>>t;
while(t--)
{
double s[10005];
double Max,Min,mid;
Min=0.0;Max=0.0;
cin>>n>>f;
for(i=0; i<n; i++)
{
scanf("%d",&r);
s[i]=PI*r*r;
if(Max<s[i])
Max=s[i];
}
while(Max-Min>=eps)
{
mid=(Max+Min)/2;
p=0;
for(i=0;i<n;i++)
{
p+=(int)(s[i]/mid);
}
if(p>=f+1) //特别注意这里,根据题意是我和这f位朋友,所以这个要加上我;
Min=mid;
else
Max=mid;
}
printf("%.4lf\n",mid);
}
return 0;
}