Channel Allocation (涂颜色)(dfs)

点击打开链接

Problem Description
When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels. 

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.
 

Input
The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. <br> <br>Following the number of repeaters is a list of adjacency relationships. Each line has the form: <br> <br>A:BCDH <br> <br>which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form <br> <br>A: <br> <br>The repeaters are listed in alphabetical order. <br> <br>Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. <br>
 

Output
For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.
 

Sample Input
  
  
2 A: B: 4 A:BC B:ACD C:ABD D:BC 4 A:BCD B:ACD C:ABD D:ABC 0
 
Sample Output
  
  
1 channel needed. 3 channels needed. 4 channels needed.


//  频道问题  和最少染几种颜色问题 差不多
//  给出若干个方块 相连的方块颜色不能相同,求最少用多少颜色涂这几个方块(这个题和这个涂颜色的题意相同) 
#if 0
#include<iostream>
#include<cstring>
using namespace std;
int mapk[30][30],n;
int color[30]={555}; 

void dfs(int x)
{
	if(x==n)
	{
		int top=0;
		for(int i=0; i<n; i++)
		{
			if(color[i]>top)
				top=color[i];
		}
		if(top>1)
		cout<<top+1<<" channels needed."<<endl;
		else
		{
			cout<<top+1<<" channel needed."<<endl;
		}
	
		return;
	}
	else
	{
		
		for(int k=0; k<n; k++)             //点 x 选颜色 
		{	
			bool flag1=0;
			for(int j=0; j<n; j++)
			{
				if(mapk[x][j]==1)
				{
					if(k==color[j])
					{
						flag1=1;
						break;
					}
				}
			}
			if(flag1==0)
			{
				color[x]=k;
				break;
			}
			
		}
		dfs(x+1);
		color[x]=555; 
	}
}

int main()
{
	while(cin>>n&&n)
	{
		memset(mapk,0,sizeof(mapk));
		memset(color,555,sizeof(color));
	

		for(int i=0; i<n; i++)
		{
			string s;
			cin>>s;
			for(int k=2; k<s.size(); k++)
			{
				int j=s[k]-'A';
				mapk[i][j]=1;
			}
		}
		
		dfs(0);
	
	}
	
}
#endif 


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值