Problem Description
The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system.
Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.
The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.
Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.
The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.
Input
The first line of input is an integer T, which tells how many test cases followed. <br>The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.
Output
For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.
Sample Input
1 3 0 990 692 990 0 179 692 179 0
Sample Output
692
最小生成树:有N个点,这连接N个点的N-1条边 的权值和最小的。
这个题要求的是,连接N个点的最小距离的路径中,最长的一段距离。
这里用的
prime算法。
//最小生成树问题 Highways
#if 0
#include<iostream>
#include<cstring>
#include<stdio.h>
using namespace std;
const int MAX=501;
int a[MAX][MAX];
bool u[MAX];
int minn[MAX];
int main()
{
int t;
cin>>t;
while(t--)
{
memset(a,0,sizeof(a));
memset(u,1,sizeof(u)); //全标记成蓝点
memset(minn,0x7f,sizeof(minn));
int n;
scanf("%d",&n);
for(int i=1; i<=n; i++)
for(int j=1; j<=n; j++)
scanf("%d",&a[i][j]);
minn[1]=0;
for(int i=1; i<=n; i++)
{
int k=0;
for(int j=1; j<=n; j++)
{
if(u[j]&&minn[k]>minn[j]) //找出与白点相连的最小的蓝点
k=j;
}
u[k]=0; //标记成白点
for(int j=1; j<=n; j++)
{
if(u[j]&&(a[k][j]<minn[j])) //更改新的白点 ,与白点相连的蓝点的值
minn[j]=a[k][j];
}
}
int end=0;
for(int i=1; i<=n; i++)
{
if(minn[i]>end)
end=minn[i]; //找出路径里,距离最长的一段
}
cout<<end<<endl;
}
}
#endif