【bzoj1689】[Usaco2005 Mar]Checking an Alibi 不在场的证明

1681: [Usaco2005 Mar]Checking an Alibi 不在场的证明

Time Limit: 5 Sec   Memory Limit: 64 MB
Submit: 338   Solved: 220
[ Submit][ Status][ Discuss]

Description

A crime has been comitted: a load of grain has been taken from the barn by one of FJ's cows. FJ is trying to determine which of his C (1 <= C <= 100) cows is the culprit. Fortunately, a passing satellite took an image of his farm M (1 <= M <= 70000) seconds before the crime took place, giving the location of all of the cows. He wants to know which cows had time to get to the barn to steal the grain. Farmer John's farm comprises F (1 <= F <= 500) fields numbered 1..F and connected by P (1 <= P <= 1,000) bidirectional paths whose traversal time is in the range 1..70000 seconds (cows walk very slowly). Field 1 contains the barn. It takes no time to travel within a field (switch paths). Given the layout of Farmer John's farm and the location of each cow when the satellite flew over, determine set of cows who could be guilty. NOTE: Do not declare a variable named exactly 'time'. This will reference the system call and never give you the results you really want.

谷仓里发现谷物被盗!约翰正试图从C(1≤C≤100)只奶牛里找出那个偷谷物的罪犯.幸运的是,一个恰好路过的卫
星拍下谷物被盗前M(1≤M≤70000)秒的农场的图片.这样约翰就能通过牛们的位置来判断谁有足够的时间来盗窃谷
物.约翰农场有F(1≤F≤500)草地,标号1到F,还有P(1≤P≤1000)条双向路连接着它们.通过这些路需要的时间
在1到70000秒的范围内.田地1上建有那个被盗的谷仓. 给出农场地图,以及卫星照片里每只牛所在的位置.请判
断哪些牛有可能犯罪.

Input

* Line 1: Four space-separated integers: F, P, C, and M 
* Lines 2..P+1: Three space-separated integers describing a path: F1, F2, and T. The path connects F
1 and F2 and requires T seconds to traverse. 
* Lines P+2..P+C+1: One integer per line, the location of a cow. The first line gives the field numb
er of cow 1, the second of cow 2, etc.
第1行输入四个整数F,只C,和M;
接下来P行每行三个整数描述一条路,起点终点和通过时间.
接下来C行每行一个整数,表示一头牛所在的地点.

Output

* Line 1: A single integer N, the number of cows that could be guilty of the crime.
* Lines 2..N+1: A single cow number on each line that is one of the cows that could be guilty of the
 crime. The list must be in ascending order.
第1行输出嫌疑犯的数目,接下来一行输出一只嫌疑犯的编号.

Sample Input

7 6 5 8
1 4 2
1 2 1
2 3 6
3 5 5
5 4 6
1 7 9
1
4
5
3
7

Sample Output

4
1
2
3
4

HINT


Source

[ Submit][ Status][ Discuss]




最短路。。。

最后统计一下小等K的有几个点

这里我用SPFA来写


代码:

#include<cstring>
#include<vector>
#include<cstdio>
using namespace std;

struct data
{
	int to,w;
};

const int maxn = 2000;
const int maxn_q = 2e5;
vector<data> edge[maxn];
int q[maxn_q],exist[maxn],dis[maxn],ans[maxn],n,m,k,c,tot;

void spfa()
{
	int h = 0,t = 1;
	for (int i = 1; i <= n; i++) dis[i] = 70001;
	dis[1] = 0;
	q[t] = 1;
	exist[1] = 1;
	while (h < t)
	{
		int u = q[++h];
		exist[u] = 0;
		for (int i = 0; i < edge[u].size(); i++)
		{
			data& e = edge[u][i];
			if (dis[u] + e.w < dis[e.to])
			{
				dis[e.to] = dis[u] + e.w;
				if (!exist[e.to])
				{
					exist[e.to] = 1;
					q[++t] = e.to;
				}
			}
		}
	}
}

int main()
{
	scanf("%d%d%d%d",&n,&m,&c,&k);
	for (int i = 1; i <= m; i++)
	{
		int u,v,w;
		scanf("%d%d%d",&u,&v,&w);
		edge[u].push_back((data){v,w});
		edge[v].push_back((data){u,w});
	}
	spfa();
	for (int i = 1; i <= c; i++)
	{
		int cow;
		scanf("%d",&cow);
		if (dis[cow] <= k)
			ans[++tot] = i;
	}
	printf("%d\n",tot);
	for (int i = 1; i <= tot; i++)
		printf("%d\n",ans[i]);
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值