UVA - 1252 Twenty Questions 记忆化搜索 状态压缩

Description

Download as PDF

Consider a closed world and a set of features that are defined for all the objects in the world. Each feature can be answered with ``yes" or ``no". Using those features, we can identify any object from the rest of the objects in the world. In other words, each object can be represented as a fixed-length sequence of booleans. Any object is different from other objects by at least one feature.

You would like to identify an object from others. For this purpose, you can ask a series of questions to someone who knows what the object is. Every question you can ask is about one of the features. He/she immediately answers each question with ``yes" or ``no" correctly. You can choose the next question after you get the answer to the previous question.

You kindly pay the answerer 100 yen as a tip for each question. Because you don't have surplus money, it is necessary to minimize the number of questions in the worst case. You don't know what is the correct answer, but fortunately know all the objects in the world. Therefore, you can plan an optimal strategy before you start questioning.

The problem you have to solve is: given a set of boolean-encoded objects, minimize the maximum number of questions by which every object in the set is identifiable.

Input 

The input is a sequence of multiple datasets. Each dataset begins with a line which consists of two integers, m and n: the number of features, and the number of objects, respectively. You can assume 0 < m$ \le$11 and 0 < n$ \le$128. It is followed by n lines, each of which corresponds to an object. Each line includes a binary string of length m which represent the value (``yes" or ``no") of features. There are no two identical objects.

The end of the input is indicated by a line containing two zeros. There are at most 100 datasets.

Output 

For each dataset, minimize the maximum number of questions by which every object is identifiable and output the result.

Sample Input 

8 1 
11010101 
11 4 
00111001100 
01001101011 
01010000011 
01100110001 
11 16 
01000101111 
01011000000 
01011111001 
01101101001 
01110010111 
01110100111 
10000001010 
10010001000 
10010110100 
10100010100 
10101010110 
10110100010 
11001010011 
11011001001 
11111000111 
11111011101 
11 12 
10000000000 
01000000000 
00100000000 
00010000000 
00001000000 
00000100000 
00000010000 
00000001000 
00000000100 
00000000010 
00000000001 
00000000000 
9 32 
001000000 
000100000 
000010000 
000001000 
000000100 
000000010 
000000001 
000000000 
011000000 
010100000 
010010000 
010001000 
010000100 
010000010 
010000001 
010000000 
101000000 
100100000 
100010000 
100001000 
100000100 
100000010 
100000001 
100000000 
111000000 
110100000 
110010000 
110001000 
110000100 
110000010 
110000001 
110000000 
0 0

Sample Output 

0 
2 
4 
11 
9

大意就是给n个物品的m个属性,某人任选其中一个,每次查询可知道该物品是否满足某个属性,求最小的查询次数。由于特征数小于等于11,所以考虑状态压缩。。。上周QTECH挂的题进去凑合了一下,最后一道是状压BFS,那还是第一次真正写状压,其实状压是个很方便的东西。。以前还觉得它很可怕,其实就是把不同的状态抽象成二进制的数,通过位运算对状态进行访问和修改。

这道题读入串后首先将状态压缩成数,然后进行记忆化搜索,dp[i][j]表示在已经询问过得特征集i中,满足特征集j的物品的个数,当dp[i][j] == 1,则无需进一步查询即可得到结果 询问次数为 max(dp(s+{k},a+{k}),dp{s+{k},a}+1)。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<queue>
#include<cmath>
#include<cstring>
using namespace std;
const int MAXN = 130;
int n,m;
int p[MAXN];
int dp[(1<<11)+10][(1<<11)+10];
int solve(int s1, int s2) {
    if(dp[s1][s2]!=0x3f3f3f3f) return dp[s1][s2];
    int cnt=0;
    for(int i=0;i<n;++i)
        if((p[i]&s1)==s2) ++cnt;
    if(cnt<=1) return dp[s1][s2]=0;
    for(int i=0;i<m; ++i) {
        if(s1&(1<<i)) continue;
        int t=s1|(1<<i);
        dp[s1][s2]= min(dp[s1][s2], max(solve(t, s2),solve(t, s2^(1<<i)))+1);
    }
    return dp[s1][s2];
}
int main() {
    char s[130];
    while(~scanf("%d%d",&m,&n)&&n+m) {
        memset(dp,0x3f3f3f3f,sizeof(dp));
        for(int i=0;i<n;++i) {
            scanf("%s",s);
            p[i]=0;
            int len=strlen(s);
            for(int j=0;j<len;++j)
                if(s[j]-48==1)
                    p[i]|=1<<j;
        }
        printf("%d\n", solve(0, 0));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值