甲级PAT 1144 The Missing Number (20 分)

1144 The Missing Number (20 分)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

题目要求

找出给定序列中,从1……N中缺失的最小值

完整代码 

方法1

#include<bits/stdc++.h>
using namespace std;
map<int,bool> m;
int main(){
	int n,i,temp;
	cin>>n;
	for(i=0;i<n;i++){
		cin>>temp;
		if(temp>0){
			m[temp]=true;
		}
	}
	for(i=1;i<10000010;i++){
		if(!m[i]){
			cout<<i;
			return 0;
		}
	}
	return 0;
} 

方法2

#include<bits/stdc++.h>
using namespace std;
bool a[10000010],num=1;

int main(){
	int n,v,min=1,i;
	char c[20];
	scanf("%d",&n);
	for(i=0;i<n;i++){
		scanf("%s",c);
		if(c[0]=='-'||strlen(c)>7) continue;
		v=atoi(c);
		a[v]=true;
		while(a[min]) min++;
	}
	while(a[min]) min++;
	printf("%d",min);
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值