1046 Shortest Distance (20 分)(模拟)

92 篇文章 0 订阅

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10

5

]), followed by N integer distances D

1

D

2

D

N

, where D

i

is the distance between the i-th and the (i+1)-st exits, and D

N

is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10

4

), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10

7

.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9

3

1 3

2 5

4 1

Sample Output:

3

10

7

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <string>
#include <cctype>
#include <string.h>
#include <cstdio>
using namespace std;
int main(){
    int n;
    cin>>n;
    vector<int> dis(n+1);
    int sum=0,left,right,cnt;
    for(int i=1;i<=n;i++){
        int temp;
        cin>>temp;
        sum+=temp;
        dis[i]=sum;
    }
    cin>>cnt;
    for(int i=0;i<cnt;i++){
        cin>>left>>right;
        if(left>right)
            swap(left,right);
        int temp=dis[right-1]-dis[left-1];
        cout<<min(temp,sum-temp)<<endl;
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小火汁猛猛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值