2021-03-12

【ZOJ】1383—Binery Numbers

题目原题:

Given a positive integer n, print out the positions of all 1’s in its binary representation. The position of the least significant bit is 0.

Example

The positions of 1’s in the binary representation of 13 are 0, 2, 3.

Task

Write a program which for each data set:

reads a positive integer n,

computes the positions of 1’s in the binary representation of n,

writes the result.

Input

The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

Output

The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1’s in the binary representation of the i-th input number.

Sample Input

1
13

Sample Output

0 2 3

解题思路: 将输入的正整数不断取模求余,并用i记录第几次整除,当取余的结果是1时输出i并用空格隔开即可

注意:循环结束需要换行符,且每行的最后一个不能输出空格,因此需要简单做一个判断

AC代码:

#include <iostream>
using namespace std; 

int main(int argc, char** argv) {
	int n;
	cin>>n;
	while(n--)
	{
		int integer;
		cin>>integer;
		int i=0; 
		while(integer != 0)
		{
			if(integer%2==1)
			{
				if(integer/2!=0)
					cout<<i<<" ";
				else
					cout<<i;
			}
			i++;
			integer /= 2;
		}
		cout<<endl;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值