zoj1944 Tree Recovery

Tree Recovery(Time Limit: 2000 msMemory Limit: 65536 KB)

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.

This is an example of one of her creations:

         D
        / <br>        /   <br>       B     E
     / &nbsp;    <br>     /   \     <br>    A     C     G
              /
             /
            F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.

However, doing the reconstruction by hand, soon turned out to be tedious.

So now she asks you to write a program that does the job for her!


Input

The input will contain one or more test cases.

Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)

Input is terminated by end of file.


Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).


Sample Input

DBACEGF ABCDEFG
BCAD CBAD


Sample Output

ACBFGED
CDAB

Analysis:

1. Firstly,we owned a tree information for preoder and inoder traversal.

2. Secondly, we can use preoder traversal to confirm the root of each small tree, while using inorder traversal to confirm the shape of tree.

#include<bits/stdc++>
using namespace std;

string pre;//preorder traversal

void postorder(string inorder) {
	if (inorder.length() == 0) { //no node
		return;
	}
	char a = pre[0];//current tree's root node
	preorder = preorder.substr(1);// remove the used root node
    //find this root node's position
	int pos = 0;
	for (int i = 0; i < inorder.length(); i++) {
		if (a == inorder[i]) {
			pos = i;
			break;
		}
	}
	string inorderLeft = inorder.substr(0, pos);//inorder traversal of the left subtree of the current tree
	string inorderRight = inorder.substr(pos + 1);//inorder traversal of the right subtree of the current tree
	postorder(inorderLeft);//the left subtree's traversal
	postorder(inorderRight);//the right subtree's traversal
	cout << a;
}
int main() {
	string in;//inorder traversal
	while (cin >> pre >> in) {
		post(in);
		cout << endl;
	}
	return 0;
}

Conclusion:

we can say that the preoder traversal is used for finding the root of each tree, while the inorder traversal is used for confirming the shape of each tree.

Stuck points:

I have no idea how to combine these two traversals to confirem the root node of each tree. The key point of solving this problem is use substr string function to confirm two subtrees. 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值