Find The Multiple
Time Limit: 1000MS Memory Limit: 10000KB 64bit IO Format: %lld & %llu
Submit
Status
Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
#include<stdio.h>
#include<cstring>
#include<queue>
#include<algorithm>
#include<functional>
#include<vector>
#include<iomanip>
#include<math.h>
#include<iostream>
using namespace std;
typedef long long ll;
int main()
{
ll n,u;
queue<ll> Q;
while (cin>>n&&n)
{
while (!Q.empty())
Q.pop();
Q.push(1);
while(!Q.empty())
{
u=Q.front();
Q.pop();
if (u%n==0)
{
cout<<u<<endl;
break;
}
else
{
Q.push(u*10);
Q.push(u*10+1);
}
}
}
return 0;
}