【三分】Expanding Rods

Expanding Rods
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u

Description

When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion. 
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment. 

Your task is to compute the distance by which the center of the rod is displaced. 

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision. 

Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output

61.329
225.020
0.000
 
   
 
   
 
   
题目意思是 已经知道图中的弧线和直线的长度 ,求弧线中心和直线中心的距离。
可以推出公式 。然后用三分法,本题目并不是完全的单调函数 ,不应该用二分法。
坑点多 卡精度 e-12 ,然后n,l,c任意一个为0时应该输出0
 
   
 
   
#include<cstdio>
#include<cstring>
#include<cmath>

using namespace std;
//double eps=1e-12;

double l,n,c;
  double ll;

bool ok(double x)
{

    if(sin(x)-l*x/ll>=0)
        return 1;
    else
        return 0;

}
int main()
{

    while(scanf("%lf%lf%lf",&l,&n,&c)!=EOF)
    {
        if(l<0&&n<0&&c<0)
            break;

            if(l==0||n==0||c==0)
            {
                puts("0.000");
                continue;
            }
       ll=(1+n*c)*l;
       double le=0;
       double ri=90;
       while(ri-le>1e-12)
       {
           double mid=(le+ri)/2;
            double mm=(mid+ri)/2;
           if(ok(mid))
           {
               le=mid;
           }
           else
            {
              //  ri=mid;
               ri=mm;
            }

       }


        printf("%.3f\n",ll/2/ri*(1-cos(ri)));
    }


    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
DataFrame expanding 是用于在 Pandas 中执行 rollingexpanding 操作的方法之一。它可以用来计算滚动或扩展窗口中的统计数据,例如滚动平均值、滚动标准偏差等。 rolling 操作是指对于一个固定大小的窗口,沿着时间序列向前滑动,对窗口中的数据进行统计运算。而 expanding 操作是指从数据集的起始点开始,逐步扩大窗口的大小,对窗口中的数据进行统计运算。 下面是一个简单的示例,展示如何使用 expanding 方法计算累计和: ```python import pandas as pd # 创建一个包含随机整数的 DataFrame df = pd.DataFrame({'data': [1, 2, 3, 4, 5]}) # 使用 expanding 方法计算累计和 expanding_sum = df['data'].expanding().sum() print(expanding_sum) ``` 输出结果为: ``` 0 1.0 1 3.0 2 6.0 3 10.0 4 15.0 Name: data, dtype: float64 ``` 这里,我们使用 `expanding()` 方法创建了一个扩展窗口,并对 `data` 列进行累计求和。由于这是一个扩展窗口,因此在每一行中,我们都计算了从数据集起始点开始的所有值的累计和。 类似地,rolling 方法也可以用于计算滚动窗口内的统计数据。例如,以下代码演示了如何使用 rolling 方法计算一个窗口大小为 3 的滚动均值: ```python import pandas as pd # 创建一个包含随机整数的 DataFrame df = pd.DataFrame({'data': [1, 2, 3, 4, 5]}) # 使用 rolling 方法计算滚动均值 rolling_mean = df['data'].rolling(window=3).mean() print(rolling_mean) ``` 输出结果为: ``` 0 NaN 1 NaN 2 2.000000 3 3.000000 4 4.000000 Name: data, dtype: float64 ``` 这里,我们使用 `rolling()` 方法创建了一个大小为 3 的滚动窗口,并对 `data` 列进行滚动均值计算。在前两个行中,由于窗口大小不够,因此没有计算出平均值,因此这些行中的值为 NaN。在第三行中,我们计算了前三个值的平均值,并将其赋值给了第三个行。以此类推,直到最后一个行,我们计算了前五个值的平均值,得到了 4.0。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值