直连路由的建立和管理

Router>en

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#host R3

R3(config)#int f0/0

R3(config-if)#ip add 172.16.10.2 255.255.255.0

R3(config-if)#no shut

R3(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R3(config-if)#exit

R3(config)#int f1/0

R3(config-if)#ip add 172.16.3.3 255.255.255.0

R3(config-if)#no shut

R3(config-if)#

%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0, changed state to up

R3(config-if)#exit

R3(config)#router rip

R3(config-router)#ver 2

R3(config-router)#no auto

R3(config-router)#no auto-summary

R3(config-router)#network 172.16.3.0

R3(config-router)#net 172.16.10.0

R3(config-router)#pass

R3(config-router)#passive-interface f0/0

R3(config-router)#exit

R3(config)#int f0/0

R3(config-if)#stand

R3(config-if)#standby 1 pri

R3(config-if)#standby 1 priority 150

R3(config-if)#standby 1 ip 172.168.10.1

% Warning: address is not within a subnet on this interface

R3(config-if)#standby 1 ip 172.16.10.1

R3(config-if)#standby 1 pree

R3(config-if)#standby 1 preempt

R3(config-if)#

%HSRP-6-STATECHANGE: FastEthernet0/0 Grp 1 state Speak -> Standby

%HSRP-6-STATECHANGE: FastEthernet0/0 Grp 1 state Standby -> Active

R3(config-if)#standby 1 tra

R3(config-if)#standby 1 track f1/0

R3(config-if)#do show standby

FastEthernet0/0 - Group 1

State is Active

9 state changes, last state change 00:17:28

Virtual IP address is 172.16.10.1

Active virtual MAC address is 0000.0C07.AC01

Local virtual MAC address is 0000.0C07.AC01 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 0.289 secs

Preemption enabled

Active router is local

Standby router is 172.16.10.3

Priority 150 (default 100)

Track interface FastEthernet1/0 state Up decrement 10

Group name is hsrp-Fa0/0-1 (default)

R3(config-if)#standby 1 pri

R3(config-if)#standby 1 priority 90

R3(config-if)#

%HSRP-6-STATECHANGE: FastEthernet0/0 Grp 1 state Speak -> Standby

R3(config-if)#do show standby

FastEthernet0/0 - Group 1

State is Standby

13 state changes, last state change 00:30:26

Virtual IP address is 172.16.10.1

Active virtual MAC address is 0000.0C07.AC01

Local virtual MAC address is 0000.0C07.AC01 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 0.039 secs

Preemption enabled

Active router is 172.16.10.3, priority 140 (expires in 9 sec)

MAC address is 0000.0C07.AC01

Standby router is local

Priority 90 (configured 90)

Track interface FastEthernet1/0 state Up decrement 10

Group name is hsrp-Fa0/0-1 (default)

R3(config-if)#standby 1 priority 150

R3(config-if)#

%HSRP-6-STATECHANGE: FastEthernet0/0 Grp 1 state Standby -> Active

R3(config-if)#standby 1 priority 90

R3(config-if)#

%HSRP-6-STATECHANGE: FastEthernet0/0 Grp 1 state Speak -> Standby

Router>en

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#host R1

R1(config)#int f0/0

R1(config-if)#ip add 172.16.10.3

% Incomplete command.

R1(config-if)#ip add 172.16.10.3 255.255.255.0

R1(config-if)#no shut

R1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

R1(config)#int f1/0

R1(config-if)#ip add 172.16.2.1 255.255.255.0

R1(config-if)#noshut

^

% Invalid input detected at '^' marker.

R1(config-if)#no shut

R1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up

R1(config-if)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0, changed state to up

R1(config-if)#exit

R1(config)#route ri

R1(config-router)#ver 2

R1(config-router)#no auto

R1(config-router)#net 172.16.2.0

R1(config-router)#net 172.16.10.0

R1(config-router)#pass

R1(config-router)#passive-interface f0/0

R1(config-router)#exit

R1(config)#int f0/0

R1(config-if)#standby 1 prio 140

R1(config-if)#standby 1 ip 172.16.10.1

R1(config-if)#standby 1 pree

R1(config-if)#standby 1 preempt

R1(config-if)#standby 1 track

R1(config-if)#standby 1 track f

%HSRP-6-STATECHANGE: FastEthernet0/0 Grp 1 state Speak -> Standby

1/0

R1(config-if)#standby 1 track f1/0

R1(config-if)#do show standby

FastEthernet0/0 - Group 1

State is Standby

3 state changes, last state change 00:19:32

Virtual IP address is 172.16.10.1

Active virtual MAC address is 0000.0C07.AC01

Local virtual MAC address is 0000.0C07.AC01 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 1.348 secs

Preemption enabled

Active router is 172.16.10.2

Standby router is local

Priority 140 (default 100)

Track interface FastEthernet1/0 state Up decrement 10

Group name is hsrp-Fa0/0-1 (default)

R1(config-if)#

Router>en

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#host R2

R2(config)#int f1/0

R2(config-if)#ip add 172.16.3.2 255.255.255.0

R2(config-if)#no shut

R2(config-if)#

%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0, changed state to up

R2(config-if)#exit

R2(config)#int f0/1

R2(config-if)#ip add 172.16.2.2 255.255.255.0

R2(config-if)#no shut

R2(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

R2(config-if)#exit

R2(config)#int f1/1

R2(config-if)#ip add 172.16.31.2 255.255.255.0

R2(config-if)#no shut

R2(config-if)#

%LINK-5-CHANGED: Interface FastEthernet1/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/1, changed state to up

R2(config-if)#no ip add 172.16.31.2 255.255.255.0

R2(config-if)#ip add 172.16.31.1 255.255.255.0

R2(config-if)#do show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 3 subnets

C 172.16.2.0 is directly connected, FastEthernet0/1

C 172.16.3.0 is directly connected, FastEthernet1/0

C 172.16.31.0 is directly connected, FastEthernet1/1

R2(config-if)#do show ip bri

show ip bri

^

% Invalid input detected at '^' marker.

R2(config-if)#do show ip int bri

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 unassigned YES unset administratively down down

FastEthernet0/1 172.16.2.2 YES manual up up

Serial0/0 unassigned YES unset administratively down down

Serial0/1 unassigned YES unset administratively down down

Serial0/2 unassigned YES unset administratively down down

Serial0/3 unassigned YES unset administratively down down

FastEthernet1/0 172.16.3.2 YES manual up up

FastEthernet1/1 172.16.31.1 YES manual up up

R2(config-if)#exit

R2(config)#route ri

R2(config-router)#ver 2

R2(config-router)#no au

R2(config-router)#no auto-summary

R2(config-router)#net 172.16.2.0

R2(config-router)#net 172.16.3.0

R2(config-router)#net 172.16.31.0

R2(config-router)#pass

R2(config-router)#passive-interface f1/1

R2(config-router)#do show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 4 subnets

C 172.16.2.0 is directly connected, FastEthernet0/1

C 172.16.3.0 is directly connected, FastEthernet1/0

R 172.16.10.0 [120/1] via 172.16.3.3, 00:00:06, FastEthernet1/0

[120/1] via 172.16.2.1, 00:00:01, FastEthernet0/1

C 172.16.31.0 is directly connected, FastEthernet1/1

R2(config-router)#

R1 con0 is now available

Press RETURN to get started.

%HSRP-6-STATECHANGE: FastEthernet0/0 Grp 1 state Standby -> Active

%HSRP-6-STATECHANGE: FastEthernet0/0 Grp 1 state Speak -> Standby

%HSRP-6-STATECHANGE: FastEthernet0/0 Grp 1 state Standby -> Active

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值