A - Cow Bowling

A - Cow Bowling

The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though,

and line up in a standard bowling-pin-like triangle like this:

          7



        3   8



      8   1   0



    2   7   4   4



  4   5   2   6   5
Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.
Input
Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.
Output
Line 1: The largest sum achievable using the traversal rules
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output
30
Hint
Explanation of the sample:

          7

         *

        3   8

       *

      8   1   0

       *

    2   7   4   4

       *

  4   5   2   6   5
The highest score is achievable by traversing the cows as shown above.


思路:将数据存储在二维数组中,从后往前依次往上相加,从最后一行开始,紧连的两个数据相比较,把大的数据往上相加,加到第一行时的数据是最大的也是我们要求出的。



#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<stdlib.h>
#include<string.h>
using namespace std;
	int g[1000][1000];  //转为全局变量,数组开的太大
	int dp[1000][1000];
int main(){
	int T,i,j;
	while(scanf("%d",&T)!=EOF){	
	memset(g,0,sizeof(g));
	memset(dp,0,sizeof(dp));
	for(i=0;i<T;i++){
		for(j=0;j<=i;j++){
			scanf("%d",&g[i][j]);
		}
	}
	for(i=T-1;i>=0;i--){
		for(j=T-1;j>=0;j--){
			dp[i][j]=max(dp[i+1][j],dp[i+1][j+1])+g[i][j];
		}
	}
	int p=-1;
	for(i=0;i<=T;i++){
		for(j=0;j<T;j++){
			if(dp[i][j]>p)
			p=dp[i][j];
		}
	}
	printf("%d\n",p);
	}
}


#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<stdlib.h>
using namespace std;
int g[1000][1000];
int main(){
	int T;
	int i,j;
	scanf("%d",&T);
for(i=1;i<=T;i++){
	for(j=1;j<=i;j++){
		scanf("%d",&g[i][j]);
	}
}
for(i=T;i>=1;i--){
	for(j=1;j<=i;j++){
		if(g[i][j]>g[i][j+1]){
			g[i-1][j]+=g[i][j];
		}else{
			g[i-1][j]+=g[i][j+1];
		}
	}
}
printf("%d\n",g[1][1]);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值