POJ 3176 Cow Bowling

题意:
   给一个n层的数据,要求从上至下每层取一个数据,并且只能取该数据下对应的两个数据中的一个,求所取数据之和最大是多少(讲的有点绕口。。)

样例:
    7
   3 8
  8 1 0
 2 7 4 4
4 5 2 6 5

解析:
    根据所给的样例以及题意,我第一反应时用递归去求出最大值,写完代码之后感觉不用这么麻烦啊,这样递归求出的最大值耗时太长了,于是又改了思路,要从上向下求最大值,那反过来,把最下面一层数据取最大值往上加,最终求出的值中一定有个最大值




                                                                                                                               Cow Bowling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14231 Accepted: 9452

Description

The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:

          7



        3   8



      8   1   0



    2   7   4   4



  4   5   2   6   5
Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample:

          7

         *

        3   8

       *

      8   1   0

       *

    2   7   4   4

       *

  4   5   2   6   5
The highest score is achievable by traversing the cows as shown above.

Source

USACO 2005 December Bronze


#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int a[355][355];
int main()
{
	int n;
	int i,j;
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		for(j=0;j<=i;j++)
			scanf("%d",&a[i][j]);
	}
	for(i=n-2;i>=0;i--)//从最后一层开始往上求出最值
	{
		for(j=0;j<=i;j++)
		{
			if(a[i+1][j]>a[i+1][j+1])//找出相邻两个数据的最值
				a[i][j]+=a[i+1][j];
			else
				a[i][j]+=a[i+1][j+1];
		}
	}
	int t=a[0][0];
	for(i=0;i<n;i++)
		if(t<a[0][i])
			t=a[0][i];
	printf("%d\n",t);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值