动态规划 Cow Bowling

        The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:

          7



        3   8



      8   1   0



    2   7   4   4



  4   5   2   6   5
Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.
Input
Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.
Output
Line 1: The largest sum achievable using the traversal rules
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output
30
Hint
Explanation of the sample:

          7

         *

        3   8

       *

      8   1   0

       *

    2   7   4   4

       *

  4   5   2   6   5
The highest score is achievable by traversing the cows as shown above.    
1.以后最好把数组定义成全局变量,避免不必要的麻烦。

2. 解题思路就是第i层的第j个,加上下面一层的最优解:dp[i][j]=dp[i][j]+max(dp[i+1][j],dp[i+1][j+1]);


#include<string.h>
#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
int dp[500][500];
int main()
{


    int n;
    while(cin>>n)
    {
        for(int i=0;i<n;i++)
            for(int j=0;j<=i;j++)
               cin>>dp[i][j];
       for(int i=n-1;i>=0;i--)
       {


           for(int j=0;j<=i;j++)
           {


               dp[i][j]=dp[i][j]+max(dp[i+1][j],dp[i+1][j+1]);
           }
       }
       cout<<dp[0][0]<<endl;


    }
    return 0;
}   
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值