B - Red and Black // dfs 深度搜索

B - Red and Black


There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13
思路:简单的dfs搜索,判断这个@符号的上下左右四个方向的位置是否为  ' . ' ,如果为 ' . ',的话,就可一走,如果不是的话,就要看其他方向,找出其中最多可以走多少。
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<stdlib.h>
#include<string.h>
using namespace std;
int m,n;//n代表列,m代表行
int cnt;
char mp[100][100];
void dfs(int p,int q){//p是行 q是列
  if(mp[p][q]!='.' || p<0 || q<0 || p>=m||q>=n){
    return ;
  }else{
      cnt++;
      mp[p][q]='#';
  dfs(p-1,q);
  dfs(p,q+1);
  dfs(p+1,q);
  dfs(p,q-1);
  }
}
int main(){
int i,j;
while(scanf("%d%d",&n,&m)!=EOF){
     cnt=0;
    memset(mp,0,sizeof(mp));
    if(n==0 && m==0){
        break;
    }
    for(i=0;i<m;i++){
        for(j=0;j<n;j++){
            cin>>mp[i][j];
        }
        //getchar();
    }
  for(i=0;i<m;i++){
    for(j=0;j<n;j++){
        if(mp[i][j]=='@'){
           mp[i][j]='.';
            dfs(i,j);
        }
    }
  }
  cout<<cnt<<endl;
}
return 0;
}

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
using namespace std;
char mp[100][100];
int cnt;
int n,m;
void f(char mp[100][100],int x,int y){
  mp[x][y]='#';
  if(x+1<m && mp[x+1][y]=='.'){
    cnt++;
    f(mp,x+1,y);
  }
   if(x-1>-1 && mp[x-1][y]=='.'){
    cnt++;
    f(mp,x-1,y);
  }
   if(y+1<n && mp[x][y+1]=='.'){
    cnt++;
    f(mp,x,y+1);
  }
   if(y-1>-1 && mp[x][y-1]=='.'){
    cnt++;
    f(mp,x,y-1);
  }
}
int main(){
int i,j;
 while(scanf("%d%d",&n,&m)!=EOF){
        if(n==0 ||m==0)
           break;
       for(i=0;i<m;i++){
        scanf("%s",&mp[i]);
       }
       for(i=0;i<m;i++){
        for(j=0;j<n;j++){
            if(mp[i][j]=='@'){
                cnt=1;
                f(mp,i,j);
                printf("%d\n",cnt);
            }
        }
       }
 }
}

自己的代码

经典的搜索题目,深度优先搜索,其描述如下:
void dfs()
{
   for(所有的邻接节点)
  {
      if(节点没有被遍历)
      {
          标记此节点;
          dfs(此节点);
      }
  }
}

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
#include<math.h>
using namespace std;
char mp[21][21];
int v[21][21];
int m,n;
int cnt=0;
int dir[4][2]={{0,1},{0,-1},{-1,0},{1,0}};
//int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
void dfs(int w,int e)
{
    for(int i=0;i<4;i++)
    {
        int ww=w+dir[i][0];
        int ee=e+dir[i][1];
       // cout<<"ww* "<<ww<<"ee* "<<ee<<endl;
        if(mp[ww][ee]=='.'&&ww>=0&&ww<n&&ee>=0&&ee<m)
        {
            cnt++;
            v[ww][ee]=1;
            mp[ww][ee]='#';
           // cout<<"ww= "<<ww<<"ee= "<<ee<<endl;
            dfs(ww,ee);
        }
    }
}
int main()
{
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        int x,y;
        memset(mp,0,sizeof(mp));
        memset(v,0,sizeof(v));
        if(m==0 ||n==0)
            break;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                cin>>mp[i][j];
                if(mp[i][j]=='@')
                {
                    x=i;
                    y=j;
                }
            }
        }
      // cout<<"x= "<<x<<"y= "<<y<<endl;
        mp[x][y]='#';
        cnt=1;
        dfs(x,y);
        printf("%d\n",cnt);
    }
    return 0;
}

或者  

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
#include<math.h>
using namespace std;
char mp[21][21];
int v[21][21];
int m,n;
int cnt=0;
int dir[4][2]={{0,1},{0,-1},{-1,0},{1,0}};
//int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
void dfs(int w,int e)
{
    for(int i=0;i<4;i++)
    {
        int ww=w+dir[i][0];
        int ee=e+dir[i][1];
        //cout<<"ww* "<<ww<<"ee* "<<ee<<endl;
        if(mp[ww][ee]=='.'&&ww>=0&&ww<n&&ee>=0&&ee<m&&v[ww][ee]==0)
        {
            cnt++;
            v[ww][ee]=1;
            mp[ww][ee]='#';
           // cout<<"ww= "<<ww<<"ee= "<<ee<<endl;
            dfs(ww,ee);
        }
    }
}
int main()
{
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        int x,y;
        memset(mp,0,sizeof(mp));
        memset(v,0,sizeof(v));
        if(m==0 ||n==0)
            break;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                cin>>mp[i][j];
                if(mp[i][j]=='@')
                {
                    x=i;
                    y=j;
                }
            }
        }
      // cout<<"x= "<<x<<"y= "<<y<<endl;
        mp[x][y]='#';
        v[x][y]=1;
        cnt=1;
        dfs(x,y);
        printf("%d\n",cnt);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值