POJ 2407 Relatives 【容斥】

题目链接:http://poj.org/problem?id=2407

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16335 Accepted: 8278

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4

思路:题目意思是让求1~n-1中与n互质的数的个数(用到了容斥定理),欧拉解法以后补上(欧拉解法已经补上)

/* 求1~n-1中与n互质的个数*/ 
//#include<bits/stdc++.h>
#include<iostream> 
int temp[100];
int num;
using namespace std;
typedef long long ll;
void out(ll n){    // 分解质因子 
		num=0;
		for(int i=2;i*i<=n;i++)
		{
			if(n%i==0)
			{
				temp[num++]=i;
				while(n%i==0)
				  n=n/i;
			}
		}
		if(n>1)
		  temp[num++]=n;
/*		for(int i=0;i<num-1;i++)
		  cout<<temp[i]<<" ";
		  cout<<temp[num-1]<<endl;  */}
ll zjj(ll t){   //返回互质的个数 
	ll ans,res,sum=0;     //先求出不互质的,用到了容斥定理 
	for(int i=1;i<(1<<num);i++)
	{
		ans=1,res=0;
		for(int j=0;j<num;j++)
		{
			if(1&i>>j)
			{
				ans=ans*temp[j];
				res++;
			}
		}
		if(res&1)
		   sum+=t/ans;
		else
		   sum-=t/ans;
	}
	return t-sum;   //总数减去不互质的即为互质的 
}
int main(){
	ll t;
	while(cin>>t&&t){
		out(t);
		cout<<zjj(t)<<endl;
	}
	return 0;
}

欧拉函数解法:

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
typedef long long ll;
ll uler(int n)
{
    ll res = n;
    for(int i=2;i*i<=n;i++)
    {
        if(n%i==0)
            res = res/i*(i-1);
        while(n%i==0)
            n/=i;
    }
    if(n!=1)
        res = res/n*(n-1);
    return res;
}
int main()
{
    int n;
    while(cin>>n && n)
    {
        cout<<uler(n)<<endl;
    }
    return 0;
}

ps:本着一颗不甘的心奋战在ACM

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值