hdu 1051 Wooden sticks 【贪心】

题目就点击这里啊:http://acm.hdu.edu.cn/showproblem.php?pid=1051

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25591    Accepted Submission(s): 10370


 

Problem Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

 

 

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

 

 

Output

The output should contain the minimum setup time in minutes, one per line.

 

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1

Sample Output

2
1
3

题意:有一堆棒子,要求你找到最小的时间来处理一个给定的一堆棒子,有提示,(1)第一根棒子的设置时间为1min。(2)之后处理的棒子的长度为l,权重为w,如果l<=l' && w<=w',就不需要设置棒子的设置时间,否则,需要1min的时间进行设置。

思路:先排序,如果l相同,按照w从小到大,否则按照l从小到大排序。l<=l' && w<=w'包含的潜在意思是后面的棒子要>=前面的每一个棒子的l和w。这是贪心的主要步骤,依靠这个进行贪心!

#include<bits/stdc++.h>
using namespace std;
const int maxn = 5e3+10;
struct inp{
	int l;
	int w;
	int flag;
}p[maxn];
bool cmp(inp a,inp b){  //排序
	if(a.l==b.l)
	   return a.w<b.w;
	return a.l<b.l; 
} 
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		int n;
		cin>>n;
		for(int i=0;i<n;i++)
		{
		   cin>>p[i].l>>p[i].w;
		   p[i].flag = 0;
	    }
		sort(p,p+n,cmp);
		int ans = 0;
		int k; 
        //下面是本题的核心贪心操作
		for(int i=0;i<n;i++)
		{
			if(p[i].flag)
			   continue;
			ans++;
			k=i;
			for(int j=i+1;j<n;j++)  
			{
				if(p[j].l>=p[k].l && p[j].w>=p[k].w && !p[j].flag)
				{
					p[j].flag=1;
					k=j;
				}
			}	
		}
		cout<<ans<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值