hdu 2899 Strange fuction 【二分+数学函数求导】

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2899

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10131    Accepted Submission(s): 6835

Problem Description

Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.

 Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

 Output

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample input

2
100
200

Sample output

-74.4291
-178.8534

分析:这是一道数学题,也是第一道整理的二分题,开个头!说白了,这道题就是让你用数学知识求函数最小值。二分对精度控制一下即可。代码:

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
double solve(double x,double y)
{
    return 6*pow(x,7) + 8*pow(x,6) + 7*pow(x,3) + 5*pow(x,2) - y*x;
}
double w(double x,double y)
{
    return 42*pow(x,6) + 48*pow(x,5) + 21*pow(x,2) + 10*x - y;
}

int main()
{
    ios::sync_with_stdio(false);
    int t;
    double l,r,mid; //第一次定义成了int,输出结果都不显示
    double y;
    cin>>t;
    while(t--)
    {
        cin>>y;
        l = 0;
        r = 100;
        mid = (l+r)/2;
        while(fabs(w(mid,y)) > 0.000001)
        {
            if(w(mid,y) >= 0) //这种情况说明一阶倒数等于0的根在(l,mid)之间
            {
                r = mid;
                mid = (l+r)/2;
            }
            else //这种情况说明一阶倒数等于0的根在(mid,r)之间
            {
                l = mid;
                mid = (l+r)/2;
            }
        }
        printf("%.4f\n",solve(mid,y)); //注意在G++中提交用%f
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值