HDU - 2899 Strange fuction(三分)

Now, here is a fuction: 
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100) 
Can you find the minimum value when x is between 0 and 100.

Input

 The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output 

 Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input

2
100
200

Sample Output

-74.4291
-178.8534

    题目大意就是求0\leq x\leq 100时函数的最小值,用三分的人比较少,但三分在求最值问题上更直观,更方便。

    三分的主要思想就是将函数线分成三份(在\frac{1}{3}\frac{2}{3}处切分),不断舍弃远离极值的那一部分。

    上代码

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

double y;
double fx(double x){
	return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;
}

int main() {
	int t;
	double midl,midr,left,right;
	cin>>t;
	while(t--){
		left=0;
		right=100;
		cin>>y;
/*******************三分********************/		
		while((right-left)>=1e-6){
			midl=(left+right)/2;
			midr=(midl+right)/2;
			double cmidl=fx(midl);
			double cmidr=fx(midr);
			if(cmidl<cmidr)//舍弃远离最小值的那一端 
				right=midr;
			else
				left=midl;
		}
		printf("%.4lf\n",fx((left+right)/2));//将得到的x值代入方程中即为结果           
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值