HDU 6324 Problem F. Grab The Tree(思维)

Problem F. Grab The Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 250    Accepted Submission(s): 163


 

Problem Description

Little Q and Little T are playing a game on a tree. There are n vertices on the tree, labeled by 1,2,...,n, connected by n−1 bidirectional edges. The i-th vertex has the value of wi.
In this game, Little Q needs to grab some vertices on the tree. He can select any number of vertices to grab, but he is not allowed to grab both vertices that are adjacent on the tree. That is, if there is an edge between x and y, he can't grab both x and y. After Q's move, Little T will grab all of the rest vertices. So when the game finishes, every vertex will be occupied by either Q or T.
The final score of each player is the bitwise XOR sum of his choosen vertices' value. The one who has the higher score will win the game. It is also possible for the game to end in a draw. Assume they all will play optimally, please write a program to predict the result.

 

 

Input

The first line of the input contains an integer T(1≤T≤20), denoting the number of test cases.
In each test case, there is one integer n(1≤n≤100000) in the first line, denoting the number of vertices.
In the next line, there are n integers w1,w2,...,wn(1≤wi≤109), denoting the value of each vertex.
For the next n−1 lines, each line contains two integers u and v, denoting a bidirectional edge between vertex u and v.

 

 

Output

For each test case, print a single line containing a word, denoting the result. If Q wins, please print Q. If T wins, please print T. And if the game ends in a draw, please print D.

 

 

Sample Input

 

1 3 2 2 2 1 2 1 3

 

 

Sample Output

 

Q

题意:给你一个无向树,每个点有点权。小Q可以从中任选一些不相邻的点,这些点的异或值若大于剩下的点的异或值,那么输出Q,相等则输出D,否则输出T。

由异或运算的性质:

异或运算通常用于对二进制的特定一位进行取反操作。

运算规律:

①a^b^c==a^(b^c)==(a^b)^c;

②d=a^b^c ==> a=b^c^d;

③a^a==0;

④x^0==x,1^num==~num;

因此我们按相不相邻分成两个点集,分别做异或,若两个值相等则一定是Q,否则就是D(也就是不存在T的情况)

代码:

#include<bits/stdc++.h>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=100010;
int n,m,k,ans,flag,cnt,tmp;
int x,y,z;
int a[maxn],vis[maxn];
vector<int>vc[maxn];
void dfs(int k,int f)
{
    vis[k]=1;
    //cout<<ans<<tmp<<" "<<a[k]<<endl;
    if(f&1) ans=ans^a[k];
    else tmp=tmp^a[k];
    //cout<<ans<<tmp<<endl;
    for(int i=0;i<vc[k].size();i++)
    {
        int v=vc[k][i];
        if(!vis[v])dfs(v,f^1);
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=n;i++)
        {
            vc[i].clear();
            scanf("%d",&a[i]);
        }
        for(int i=1;i<n;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            vc[x].push_back(y);
            vc[y].push_back(x);
        }
        ans=0;tmp=0;
        dfs(1,1);
        //cout<<ans<<tmp<<endl;
        if(ans==tmp)printf("D\n");
        else printf("Q\n");
    }
      //  if(flag) puts("Yes"); else puts("No");
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值