hdu 1059 Dividing 多重背包

Dividing

                                                                             Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case.
 

Sample Input
  
  
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output
  
  
Collection #1: Can't be divided. Collection #2: Can be divided.
题意就是有一些石头,他们有不同的体积、价值和数量,每组数据输入六个数,代表每种石头的数量,i从1开始编号,i即代表石头的体积,又代表石头的价值。如果两个人可以平分这些石头,即分得的价值一样大,输出“ Can be divided.”,否则输出“Can't be divided."。
参考代码一:
#include<stdio.h>
#include<string.h>
int dp[120002],a[6];  //注意dp数组要不小于120000
int max(int a,int b)
{
    return a>b?a:b;
}
void CompletePack(int v,int w,int m)
{
    for(int i=v;i<=m;i++)
      dp[i]=max(dp[i],dp[i-v]+w);
}
void ZeroOnePack(int v,int w,int m)
{
    for(int i=m;i>=v;i--)
     dp[i]=max(dp[i],dp[i-v]+w);
}
void MultiPack(int v,int w,int m,int c)
{
	if(v*c>=m)
		CompletePack(v,w,m);
	else
	{
		int k=1;
		while(k<c)
		{
			ZeroOnePack(k*v,k*w,m);
			c-=k;
			k*=2;
		}
		ZeroOnePack(c*v,c*w,m);
	}
}
int main()
{
    int i,sum,count,t=0,s;
    while(1)
    {
        count=sum=0;
        for(i=1;i<=6;i++)
        {
            scanf("%d",&a[i]); //a[i]为数量,i为价值和体积
            sum+=a[i]*i;
            if(a[i]==0)
              count++;
        }
        if(count==6) break;
        memset(dp,0,sizeof(dp));
        s=sum/2;
        for(i=1;i<=6;i++)
        {
          MultiPack(i,i,s,a[i]);
	}
          printf("Collection #%d:\n",++t);
          if(dp[s]==sum-dp[s])
            printf("Can be divided.\n");
          else
            printf("Can't be divided.\n");
        printf("\n");
    }
    return 0;
}
参考代码二:
#include<stdio.h>
#include<string.h>
int dp[120002],a[6];
int max(int a,int b)
{
    return a>b?a:b;
}
void CompletePack(int v,int w,int m)
{
    for(int i=v;i<=m;i++)
      dp[i]=max(dp[i],dp[i-v]+w);
}
void ZeroOnePack(int v,int w,int m)
{
    for(int i=m;i>=v;i--)
     dp[i]=max(dp[i],dp[i-v]+w);
}
int main()
{
    int i,sum,count,t=0,s;
    while(1)
    {
        count=sum=0;
        for(i=1;i<=6;i++)
        {
            scanf("%d",&a[i]); //a[i]为数量,i为价值
            sum+=a[i]*i;
            if(a[i]==0)
              count++;
        }
        if(count==6) break;
        memset(dp,0,sizeof(dp));
        s=sum/2;
        for(i=1;i<=6;i++)
        {
            if(a[i]*i>=s)
              CompletePack(i,i,s);
            else
            {
                int k=1;
                while(k<a[i])
                {
                    ZeroOnePack(k*i,k*i,s);
                    a[i]-=k;
                    k*=2;
                }
                ZeroOnePack(a[i]*i,a[i]*i,s);
            }
        }
          printf("Collection #%d:\n",++t);
          if(dp[s]==sum-dp[s])
            printf("Can be divided.\n");
          else
            printf("Can't be divided.\n");
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值