POJ 3259 Wormholes

Language:Default

Wormholes

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 66713 Accepted: 24868

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

 

 

思路:其实这个题目就是要求判断是否存在负环,如果有输出YES,没有的话输出NO,我用spfa写了BFS和DFS判断负环的俩个代码,大家可以参考下,但是这道题目用DFS耗时900多ms,而bfs确实600多ms,有点惊讶

 SPFA+DFS:

#include<iostream>
#include<queue>
using namespace std;
const int maxn = 2e5 + 7;
const int inf = 1e9;
struct node{
    int next;
    int w;
    int to;
}edge[maxn];
int n, m, t, a, b, c, w, cnt;
int d[maxn], num[maxn], head[maxn];
bool vis[maxn];
void add(int u, int v, int w) {
    edge[cnt].w = w;
    edge[cnt].to = v;
    edge[cnt].next = head[u];
    head[u] = cnt++;
}
int flag;
void spfa(int s) {
    vis[s] = 1;
    for (int i = head[s]; i != 0; i = edge[i].next){
        int w = edge[i].w;
        int v = edge[i].to;
        if (d[s] + w < d[v]) {
            if (vis[v]) {
                flag = 1;
                return;
            }
            d[v] = d[s] + w;
            spfa(v);
        }
    }
    vis[s] = 0;
}

int main() {
    cin >> t;
    while (t--) {
        fill(head, head + maxn, 0);
        fill(vis, vis + maxn, false);
        fill(d, d + maxn, inf);
        cin >> n >> m >> w;
        cnt = 1;
        for (int i = 0; i < m; i++) {
            cin >> a >> b >> c;
            add(a, b, c);
            add(b, a, c);
        }
        for (int i = 0; i < w; i++) {
            cin >> a >> b >> c;
            add(a, b, -c);
        }
        flag = 0;
        d[1] = 0;
        spfa(1);
        if (flag) cout << "YES" << endl;
        else cout << "NO" << endl;
    }
    return 0;
}

SPFA+BFS:

#include<iostream>
#include<queue>
using namespace std;
const int maxn = 2e5 + 7;
const int inf = 1e9;
struct node{
    int next;
    int w;
    int to;
}edge[maxn];
int n, m, t, a, b, c, w, cnt;
int d[maxn], num[maxn], head[maxn];
bool inq[maxn];
void add(int u, int v, int w) {
    edge[cnt].w = w;
    edge[cnt].to = v;
    edge[cnt].next = head[u];
    head[u] = cnt++;
}
bool spfa(int s) {
    fill(d, d + maxn, inf);
    fill(num, num + maxn, 0);
    fill(inq, inq + maxn, false);
    d[s] = 0;
    num[s]++;
    queue<int> q;
    q.push(s);
    inq[s] = true;
    while (!q.empty()) {
        int u = q.front();
        q.pop();
        inq[u] = false;
        for (int i = head[u]; i != 0; i = edge[i].next) {
            int v = edge[i].to;
            int w = edge[i].w;
            if (d[u] + w < d[v]) {
                d[v] = d[u] + w;
                if (!inq[v]) {
                    inq[v] = true;
                    num[v]++;
                    q.push(v);
                    if (num[v] >= n) return false;
                }
            }
        }
    }
    return true;
}

int main() {
    cin >> t;
    while (t--) {
        fill(head, head + maxn, 0);
        cin >> n >> m >> w;
        cnt = 1;
        for (int i = 0; i < m; i++) {
            cin >> a >> b >> c;
            add(a, b, c);
            add(b, a, c);
        }
        for (int i = 0; i < w; i++) {
            cin >> a >> b >> c;
            add(a, b, -c);
        }
        if(!spfa(1)) cout << "YES" << endl;
        else cout << "NO" << endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值