Max Sum Plus Plus

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem. 

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n). 

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ iy ≤ j x or i x ≤ j y ≤ j x is not allowed). 

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^ 

Input

Each test case will begin with two integers m and n, followed by n integers S 1, S2, S 3 ... S n
Process to the end of file. 

Output

Output the maximal summation described above in one line. 

Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output

6
8


        
  

Hint

Huge input, scanf and dynamic programming is recommended.

 

思路:首先来一个二维数组来解释下,dp[i][j]表示前j个数分成i段,并且以第j个数结尾的最大的和,之后进行递推

dp[i][j] = max(dp[i][j - 1] + a[j], dp[i - 1][t] + a[j]),前者的意思是前j-1个数划分为i段的最大的和,并且把第j个数和第j-1个数划分为同一段,后者将前t个数划分为i-1段最大的和,同时第j个数为一段,最后dp[i][j]便是俩者中的最大值

图来自网络

由这张图可以看出如何计算,同时左下角的部分不需要进行计算,因为m个数无法划分为m+1段,在这道题我们使用一维数组来ac,一位数据过大,二维数组会wa,代码如下:

 

#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 1e6 + 10;
const int inf = 0x7ffffff;
int dp[maxn], pre[maxn], a[maxn]; //dp【i】为改行以i结尾划分段的最大值,pre【i】为上一行以i结尾划分段的最大值,对照图思考一下就知道意思
int n, m;

int main() {
	while (cin >> m >> n) {
		for (int i = 1; i <= n; i++) {
			cin >> a[i];
		}
		fill(dp, dp + maxn, 0);
		fill(pre, pre + maxn, 0);
		int temp;
		for (int i = 1; i <= m; i++) {
			temp = -inf; // 必须为-inf不能为0,因为可能最大和为负数
			for (int j = i; j <= n; j++) {
				dp[j] = max(dp[j - 1], pre[j - 1]) + a[j];
				pre[j - 1] = temp;
				temp = max(temp, dp[j]); //temp用来记录上一行的最大值
			}
		}
		cout << temp << endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值