hdu2473 Junk-Mail Filter-并查集(删除)

原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=2473


一:原题内容

Problem Description
Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.

Input
There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 10 5 , 1 ≤ M ≤ 10 6), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.
 
Output
For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.
 
Sample Input
  
  
5 6 M 0 1 M 1 2 M 1 3 S 1 M 1 2 S 3 3 1 M 1 2 0 0
 
Sample Output
  
  
Case #1: 3 Case #2: 2
 
二:分析理解

题意:给n个点,M a b表示将a,b合为一堆;S a表示把a从堆里删除,问最后还有几堆?

就是删除操作不好操作,我们建立一个映射数组hash1[],具体看代码。

三:AC代码

#include<iostream>    
#include<string.h>  
#include<algorithm>  
#include<set>

using namespace std;

#define N1 1000005
#define N2 100005

int hash1[N2];
int pre[N1];
int n, m;
int a, b;

int Find(int x)
{
	if (x == pre[x]) return x;
	pre[x] = Find(pre[x]);
	return pre[x];
}

void Union(int a, int b)
{
	int a_root = Find(a);
	int b_root = Find(b);
	if (a_root != b_root)
		pre[a_root] = b_root;
}

int main()
{
	int cas = 1;
	while (scanf("%d%d", &n, &m) && (n || m))
	{
		for (int i = 0; i < n; i++)
		{
			pre[i] = i;
			hash1[i] = i;
		}

		int num = n;
		char ch[5];
		while (m--)
		{
			scanf("%s", &ch);
			if (ch[0] == 'S')
			{
				scanf("%d", &a);
				hash1[a] = num++;
				pre[hash1[a]] = hash1[a];
			}
			else
			{
				scanf("%d%d", &a, &b);
				Union(hash1[a], hash1[b]);
			}
		}

		set<int> s;
		for (int i = 0; i < n; i++)
			s.insert(Find(hash1[i]));

		printf("Case #%d: %d\n", cas++, s.size());
	}


	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值