数据结构实验之二叉树七:叶子问题
Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立该二叉树并按从上到下从左到右的顺序输出该二叉树的所有叶子结点。
Input
输入数据有多行,每一行是一个长度小于
50
个字符的字符串。
Output
按从上到下从左到右的顺序输出二叉树的叶子结点。
Example Input
abd,,eg,,,cf,,, xnl,,i,,u,,
Example Output
dfg uli
#include <bits/stdc++.h>
using namespace std;
struct node
{
char data;
struct node *l,*r;
};
char st[100];
int k;
struct node *creat()
{
struct node *root;
if(st[++k]==',')
{
return NULL;
}
else
{
root = new struct node;
root ->data = st[k];
root ->l = creat();
root ->r = creat();
}
return root;
}
void leave(struct node *root)
{
struct node *tree[110];
int i = 0,j = 0;
tree[i++] = root;
while(i>j)
{
if(tree[j])
{
if(tree[j]->l==NULL&&tree[j]->r==NULL)
{printf("%c",tree[j]->data); }
tree[i++] = tree[j]->l;
tree[i++] = tree[j]->r;
}
j++;
}
cout << endl;
}
int main()
{
struct node *root;
while(~scanf("%s",st))
{
k = -1;
root = new struct node;
root = creat();
leave(root);
}
return 0;
}