数据结构实验之图论七:驴友计划
Time Limit: 1000MS
Memory Limit: 65536KB
Problem Description
做为一个资深驴友,小新有一张珍藏的自驾游线路图,图上详细的标注了全国各个城市之间的高速公路距离和公路收费情况,现在请你编写一个程序,找出一条出发地到目的地之间的最短路径,如果有多条路径最短,则输出过路费最少的一条路径。
Input
连续T组数据输入,每组输入数据的第一行给出四个正整数N,M,s,d,其中N(2 <= N <= 500)是城市数目,城市编号从0~N-1,M是城市间高速公路的条数,s是出发地的城市编号,d是目的地的城市编号;随后M行,每行给出一条高速公路的信息,表示城市1、城市2、高速公路长度、收费额,中间以空格间隔,数字均为整数且不超过500,输入数据均保证有解。
Output
在同一行中输出路径长度和收费总额,数据间用空格间隔。
Example Input
1 4 5 0 3 0 1 1 20 1 3 2 30 0 3 4 10 0 2 2 20 2 3 1 20
Example Output
3 40
#include <bits/stdc++.h>
#define INF 0x3f3f3f3f
using namespace std;
int mmp[520][520]; //建立邻接矩阵存储图
int val[520][520]; //花费
int length[520][520]; //任意两节点间总路程
int cost[520][520]; //任意两节点间总花费
int n, m, s, d;
void Folyd()
{
for(int i = 0; i < n; i++)
{
for(int j = 0; j < n; j++)
{
length[i][j] = mmp[i][j], cost[i][j] =val[i][j];
}
}
for(int k = 0; k < n; k++)
{
for(int i = 0; i < n; i++)
{
for(int j = 0; j < n; j++)
{
if(i != j)
{
if(length[i][j] > length[i][k] + length[k][j])
{
length[i][j] = length[i][k] + length[k][j];
cost[i][j] = cost[i][k] + cost[k][j];
}
if(length[i][j] == length[i][k] + length[k][j])
{
if(cost[i][j] > cost[i][k] + cost[k][j])
cost[i][j] = cost[i][k] + cost[k][j];
}
}
}
}
}
}
int main()
{
int T;
cin>>T;
while(T--)
{
cin>>n>>m>>s>>d;
for(int i = 0; i <= n; i++)
{
for(int j = 0; j <= n; j++)
{
if(i == j)
mmp[i][j] =val[i][j] = 0;
else
mmp[i][j] =val[i][j] = INF;
}
}
for(int i = 0; i < m; i++)
{
int u, v, w,x;
cin>>u>>v>>w>>x;
mmp[u][v] = mmp[v][u] = w;
val[u][v] =val[v][u] =x;
}
Folyd();
cout<<length[s][d]<<" "<<cost[s][d]<<endl;
}
return 0;
}