1274 面向对象程序设计上机练习十二(运算符重载)

1274 面向对象程序设计上机练习十二(运算符重载)

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description
处理一个复数与一个double数相加的运算,结果存放在一个double型变量d1中,输出d1的值。定义Complex(复数)类,在成员函数中包含重载类型转换运算符:operator double(){return real;}
Input
输入占两行:
第1行是一个复数的实部和虚部,数据以空格分开。
第2行是一个实数。
Output
输出占一行,复数的实部和实数之和,小数点后保留1位。
Example Input
  
  
2.3 5.4
3.4
Example Output
5.7
#include <bits/stdc++.h>
using namespace std;

class Complex
{
    public:
        Complex(double x = 0, double y = 0)
        {
            real = x;
            imag = y;
        }

        void get_in1(double x = 0, double y = 0)
        {
            cin >> x >> y;
            real = x;
            imag = y;
        }

        void get_in2(double x = 0, double y = 0)
        {
            cin >> x;
            real = x;
            imag = y;
        }

        void put_out()
        {
            cout << fixed << setprecision(1) <<real <<endl;
        }

        Complex operator + (Complex &t)
        {
            Complex x;
            x.real = t.real + real;
            x.imag = t.imag + imag;
            return x;
        }

    private:
        double real,imag;
        double x,y;
};
int main()
{
   Complex c1,c2,c3;
   c1.get_in1();
   c2.get_in2();

   c3 = c1 + c2;

   c3.put_out();
   return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值