Cheapest Palindrome

B - Cheapest Palindrome
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers:  N and  M
Line 2: This line contains exactly  M characters which constitute the initial ID string 
Lines 3..  N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

题意是要把一串不是回文序列的字符改造成回文序列的字符串,增或减一个不同字符所需的价钱是不同的,要求计算所需的最少的花费是多少。首先在没有的一边增加一个字符和在有的一边减去一个字符所能达到的效果是一样的,所以可以直接开一个数组来存改变每一个字符所需的较少的费用,然后当区间左右两端的字符相同时,不需要改造,所以直接等于去掉两端的中间的值,当不相同时,应该等于改造左边或右边较小的值。

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define inf 1e8
using namespace std;
int dp[2020][2020];
int main()
{
    int n,m,vis[30];
    while(~scanf("%d%d",&n,&m))
    {
        char a[2020];
        scanf("%s",a);
        int x,y;
        char z;
        for(int i=0;i<n;i++)
        {
            cin>>z>>x>>y;
            vis[z-'a']=min(x,y);
        }
        /*if(m==1)                //这两个可以去掉,但是加上的话时间会少很多     
        {
            printf("0\n");
            continue;
        }
        if(m==2)
        {
            dp[0][1]=min(vis[a[0]-'a'],vis[a[1]-'a']);
            printf("%d\n",dp[0][1]);
            continue;
        }*/
        for(int j=1;j<m;j++)
        {
            for(int i=j-1;i>=0;i--)
                {
                    dp[i][j]=inf;
                    if(a[i]==a[j])
                        dp[i][j]=dp[i+1][j-1];
                    else {
                        dp[i][j]=min(dp[i+1][j]+vis[a[i]-'a'],dp[i][j-1]+vis[a[j]-'a']);
                    }
                }
        }
        printf("%d\n",dp[0][m-1]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值