杭电-2641 Reward(拓扑排序)

Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7528    Accepted Submission(s): 2377

Problem Description
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
 
Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.

Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
 
Sample Input
  
  
2 1 1 2 2 2 1 2 2 1
 
Sample Output
  
  
1777 -1
 
Author
dandelion
 
Source
 
Recommend
yifenfei   |   We have carefully selected several similar problems for you:   3342  1811  2680  2094  1142 

#include<cstdio>  
#include<cstring>  
#include<queue>  
using namespace std;  
int n,indegree[10010];  
int head[20010],num[10010];  
  
struct node  
{  
    int to,next;  
}map[20010];  
  
void tuopu()  
{  
    int i,top,k=0,sum=0;  
    queue<int>q;  
    for(i=1;i<=n;++i)  
    {  
        if(indegree[i]==0)  
           q.push(i);  
    }  
    while(!q.empty())  
    {  
        top=q.front();  
        q.pop();  
        k++;//用k标记是否满足所有人需求,即不出现环   
        for(i=head[top];i!=-1;i=map[i].next)  
        {  
            indegree[map[i].to]--;  
            if(indegree[map[i].to]==0)  
            {  
                q.push(map[i].to);  
                num[map[i].to]=num[top]+1; //将下一层节点含有的值加一   
            }  
        }  
    }  
    for(i=1;i<=n;++i)  
       sum+=num[i];  
    if(k==n)//k等于n,则有向图中无环   
       printf("%d\n",sum);  
    else  
       printf("-1\n");   
}  
  
int main()  
{  
    int m,i,a,b;  
    while(scanf("%d%d",&n,&m)!=EOF)  
    {  
        memset(indegree,0,sizeof(indegree));  
        memset(head,-1,sizeof(head));  
        for(i=1;i<=n;++i)  
           num[i]=888;  
        for(i=0;i<m;++i)  
        {  
            scanf("%d%d",&a,&b);//反向存表   
            map[i].to=a;  
            map[i].next=head[b];  
            head[b]=i;  
            indegree[a]++;  
        }  
        tuopu();  
    }  
    return 0;  
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值