POJ---2828 Buy Tickets

Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 15846 Accepted: 7893

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ iN). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

Source

POJ Monthly--2006.05.28, Zhu, Zeyuan

题意:N个人买票,每个人都有一个初始的位置,按照这个初始位置排序,且后一个人可以插前一个人的队(即如果前一个人占用了后一个人的初始位置,则前一个人以后的整个队伍向后移,让出这个位置),求出最后整个队列的位置情况
/**线段树思路:
 *每个节点用来存储当前节点以下的子树总共还能存入几个人
 *叶节点表示该位置是否有人,有则为0,没有则为1
 *因为如果从第一组数据开始则需要调整后面数据的位置,所以要倒着存入数据,这样可以直接确定数据的位置
 *此时可以发现当需要放置的位置的值如果大于左子树节点的值,则这个位置一定右子树上
 *否则就在左子树上
 */


#include<iostream>
#include<cstdio>
#include<cstring>
#define N 200005
using namespace std;

int Tree[N <<2];
int ans[N];//存储数据顺序

void PushUp(int rt)
{
    Tree[rt] = Tree[rt << 1] + Tree[rt << 1 | 1];
}
void build(int l,int r,int rt)//树的初始状态,叶节点都为1
{
    int mid;
    if(l == r )
    {
        Tree[rt] = 1;
        return;
    }
    mid = (l + r) >> 1;
    build(l,mid,rt << 1);
    build(mid + 1,r,rt << 1 | 1);
    PushUp(rt);
}
void Update(int p,int v,int l,int r,int rt)//将v放入p位置上
{
    int  mid;
    if(l == r)
    {
        ans[l] = v;
        Tree[rt] = 0;
        return;
    }
    mid = (l + r) >> 1;
    if(p <= Tree[rt << 1])//如果p小于左子树节点的值,则该数据在左子树上
    {
        Update(p,v,l,mid,rt << 1);
    }
    else Update(p - Tree[rt << 1],v,mid + 1,r,rt << 1 | 1);
    PushUp(rt);
}

int main()
{
    int T;
    int i,j;
    int p[N],v[N];

    //freopen("FileIn.txt","r",stdin);
    //freopen("FileOut.txt","w",stdout);

    while(scanf("%d",&T) != EOF)
    {

        build(1,T,1);
        for(i = 1;i <= T;i++)scanf("%d%d",&p[i],&v[i]);
        //memset(ans,0,sizeof(ans));
        for(i = T;i >= 1;i--) Update(p[i] + 1,v[i],1,T,1);//题目给定初始位置是p之后,所以这里要加1
        for(j = 1;j <= T;j++) printf("%d ",ans[j]);
        printf("\n");
    }
    //fclose(stdin);
    //fclose(stdout);

    return 0;
}











  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值