1105 Spiral Matrix (25分)

26 篇文章 0 订阅

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10​4​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76

思路:黑盒测试的时候已经想到肯定会出现质数的情况(质数会导致需要一个h*1其中h会很大的数组),然后拿11这种比较小的质数测试了一下觉得没有问题。但是没有想到题目这么狠,给了一个非常大的质数,把数组开到最大的正方形都不够大,只能用vector。

#include<bits/stdc++.h>
using namespace std;
int a[10000];
vector<vector<int> > m;
int cnt=1;
bool cmp(int a, int b){
    return a>b;
}
void dg(int x, int y, int la, int lb){
    for(int i=y; i<y+lb; ++i)
        if(!m[x][i]) m[x][i]=a[cnt++];
    for(int i=x+1; i<x+la; ++i)
        if(!m[i][y+lb-1]) m[i][y+lb-1]=a[cnt++];
    for(int i=y+lb-2; i>=y; --i)
        if(!m[x+la-1][i]) m[x+la-1][i]=a[cnt++];
    for(int i=x+la-2; i>x; --i)
        if(!m[i][y]) m[i][y]=a[cnt++];
    if(la>2 || lb>2) dg(x+1, y+1, la-2, lb-2);
}
int main(){
    int n;
    scanf("%d", &n);
    for(int i=1;i<=n;++i) scanf("%d", &a[i]);
    sort(a+1, a+n+1, cmp);
    int lena = sqrt(n);
    while(n%lena) lena--;
    int lenb = n/lena;
    if(lenb>lena) swap(lena, lenb);
    m.resize(lena+1);
    for(int i=1;i<=lena;++i){
        m[i].resize(lenb+1);
        for(int j=1;j<=lenb;++j) m[i][j]=0;
    }

    dg(1,1,lena,lenb);
    for(int i=1;i<=lena;++i){
        for(int j=1;j<=lenb;++j){
            if(j!=1) printf(" ");
            printf("%d", m[i][j]);
        }
        puts("");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值