PAT甲级 1105 Spiral Matrix (25 分)模拟

113 篇文章 9 订阅

1105 Spiral Matrix (25 分)

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has mrows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10​4​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76

题目大意: 给出数矩,求出符合要求的行和列,并按照要求打印出矩阵。

参考了这篇博客,感觉逻辑处理上很清晰易懂:https://blog.csdn.net/a1eafall/article/details/51074712
首先要求出矩阵的行和列,行要大于等于列。 
对数组进行排序。 
建立一个矩阵数组,用于储存矩阵结果。 
设四个变量minR,maxR,minC,maxC,用于记录当前需要填充的行列的边界。 
填充方法按题目所述,设置当前行列,nowR,nowC,从左至右,从上到下,从右到左,从下到上进行填充。并更新行列边界值。
 

#include <iostream>
#include <algorithm>
#include <vector>
#include <cmath>
using namespace std;


int fun(int n){
	int i=sqrt(n); 
	while(i>=1){
		if(n%i==0)
			return i;
		i--;
	}
	return 1;
}

int main(){
	int n,a,b;
	cin>>n;
	a = fun(n);b = n/a;
	int row = max(a,b);
	int col = min(a,b);
	vector<int> vec(n);
	for(int i=0;i<n;i++){
		cin>>vec[i];
	}
	sort(begin(vec),end(vec));
	int arr[101][101] = {0};
	
	int index = n-1;
	int minR = 0,maxR = row-1,minC = 0,maxC = col-1;
	while(index>=0){
		for(int row=minR,col=minC;col<=maxC;col++)
			arr[row][col] = vec[index--];
		minR++;
		if(index < 0)//注意当数组值没有时,直接跳出循环 
			break; 
		for(int row=minR,col=maxC;row<=maxR;row++)
			arr[row][col] = vec[index--];
		maxC--;
		if(index < 0)
			break;
		for(int row=maxR,col=maxC;col>=minC;col--)
			arr[row][col] = vec[index--];
		maxR--;
		if(index < 0)
			break;
		for(int row=maxR,col=minC;row>=minR;row--)
			arr[row][col] = vec[index--];
		minC++;
		if(index < 0)
			break;
	}
	for(int i=0;i<row;i++){
		for(int j=0;j<col;j++){
			cout<<arr[i][j];
			if(j != col-1)
				cout<<" ";
		}
		cout<<endl;
	}
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值