POJ 1573 Robot Motion 搜索找一个循环

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12845 Accepted: 6234

Description


A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

N north (up the page) 
S south (down the page) 
E east (to the right on the page) 
W west (to the left on the page) 

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid. 

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits. 

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around. 

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)
 
 
这个我们需要一个二维数组记录每个节点第一次到达时所用的步数,这样我们如果到达一个已经访问过的点,那么我们一定是绕圈子了。
同时我们们要记录走到当前点走了几步了,那么圈子大小就是当前点走了几步减去第一次到达时走了几步。
 
#include <iostream>  
#include <cstdio>  
#include <cstring>  
#include <queue>  
using namespace std;  
struct node  
{  
    int x,y;  
    node(int x=0,int y=0):x(x),y(y) {};  
    //装X的写法  
};  
char a[15][15];  
bool vis[15][15];  
int step[15][15];  
int n,m,s;  
void BFS()  
{  
    queue<node>q;  
    memset(vis,false,sizeof(vis));  
    step[0][s-1]=0;  
    q.push(node(0,s-1));  
    int stepp=-1;  
    while(!q.empty())  
    {  
        node now=q.front();  
        q.pop();  
        stepp++;  
        if(now.x<0||now.x>=n||now.y<0||now.y>=m)  
        {  
            printf("%d step(s) to exit\n",stepp);  
            return ;  
        }  
        if(vis[now.x][now.y])  
        {  
            printf("%d step(s) before a loop of %d step(s)\n",step[now.x][now.y],stepp-step[now.x][now.y]);  
            return ;  
        }  
        vis[now.x][now.y]=true;  
        step[now.x][now.y]=stepp;  
        if(a[now.x][now.y]=='S')  
        {  
            q.push(node(now.x+1,now.y));  
        }  
        else if(a[now.x][now.y]=='N')  
        {  
            q.push(node(now.x-1,now.y));  
        }  
        else if(a[now.x][now.y]=='W')  
        {  
            q.push(node(now.x,now.y-1));  
        }  
        else if(a[now.x][now.y]=='E')  
        {  
            q.push(node(now.x,now.y+1));  
        }  
    }  
}  
int main()  
{  
    while(cin>>n>>m>>s,n,m,s)  
    {  
        for(int i=0; i<n; i++)  
            cin>>a[i];  
        BFS();  
    }  
    return 0;  
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值