DS二叉树--二叉树构建与遍历

样例输入

2

AB0C00D00

AB00C00

样例输出

ABCD

BCAD

CBDA

ABC

BAC

BCA

#include <string>
#include <string.h>
#include <iostream>
using namespace std;
 
class Node
{
public:
    char data;
    Node *left, *right;
    Node(){}
    ~Node()
    {
        delete left;
        delete right;
    }
};
void pre(Node *tree)
{
    if(tree)
    {
        cout << tree->data;
        pre(tree->left);
        pre(tree->right);
    }
}
void in(Node *tree)
{
    if(tree)
    {
        in(tree->left);
        cout << tree->data;
        in(tree->right);
    }
}
void post(Node *tree)
{
    if(tree)
    {
        post(tree->left);
        post(tree->right);
        cout << tree->data;
    }
}
 
static int i = 0;
Node *creattree(string str)
{
    Node *p = new Node;
    if(str[i] == '0')
    {
        p = NULL;
    }
    else
    {
        p->data = str[i];
        i++;
        p->left = creattree(str);
        i++;
        p->right = creattree(str);
    }
    return p;
}
 
int main()
{
    int T;
    string str;
    cin >> T;
    while(T--)
    {
        i = 0;
        Node *tree;
        cin >> str;
        tree = creattree(str);
        pre(tree);
        cout << endl;
        in(tree);
        cout << endl;
        post(tree);
        cout << endl;
        delete tree;
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值