hdu acm 5410 CRB and His Birthday

Problem Description
Today is CRB's birthday. His mom decided to buy many presents for her lovely son.
She went to the nearest shop with M Won(currency unit).
At the shop, there are N kinds of presents.
It costs Wi Won to buy one present of i -th kind. (So it costs k × Wi Won to buy k of them.)
But as the counter of the shop is her friend, the counter will give Ai × x + Bi candies if she buys x ( x >0) presents of i -th kind.
She wants to receive maximum candies. Your task is to help her.
1 ≤ T ≤ 20
1 ≤ M ≤ 2000
1 ≤ N ≤ 1000
0 ≤ Ai, Bi ≤ 2000
1 ≤ Wi ≤ 2000
 

Input
There are multiple test cases. The first line of input contains an integer T , indicating the number of test cases. For each test case:
The first line contains two integers M and N .
Then N lines follow, i -th line contains three space separated integers Wi , Ai and Bi .
 

Output
For each test case, output the maximum candies she can gain.
 

Sample Input
  
  
1 100 2 10 2 1 20 1 1
 

Sample Output
  
  
21
Hint
CRB's mom buys 10 presents of first kind, and receives 2 × 10 + 1 = 21 candies.
 

先01背包,再多重背包.

#include<iostream>
using namespace std;
#include<string.h>
#include<algorithm>
int dp[30000],v[40000],w[40000];
int main()
{
    int h,t,m,n,i,j,a,b,num,vv,ww,v1;
    int k;
    cin>>t;
    while(t--)
    {  h=0;
    memset(dp,0,sizeof(dp));
        cin>>m>>n;
       for(i=0;i<n;i++)
        {
           cin>>ww>>a>>b;
           v1=a+b;
           for(k=m;k>=ww;k--)
            dp[k]=max(dp[k],dp[k-ww]+v1);
           num=m/ww-1;
          for(j=1;j<=num;j=j*2)
          {
              v[h]=j*a;
              w[h]=j*ww;
              num=num-j;
              h++;
          }
          if(num>0)
          {
              v[h]=num*a;
              w[h]=num*ww;
              h++;
          }

        }
        for(i=0;i<h;i++)
            for(j=m;j>=w[i];j--)
            dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
        cout<<dp[m]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值