poj 1852 Ants

Ants
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 21692 Accepted: 8902

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207 

这道题看起来挺简单,第一个想法就是直接暴力?但是每个蚂蚁都有两种朝向,n只就是2^n,如果n大了铁定T了啊。所以暴力还是不行。

那就再看看题呗。

怎么最快呢?就是每个蚂蚁都向自己离得最近的那个端点走是最快的,这样遍历一遍就可以求出最短时间了;

怎么最长呢?先想想两个蚂蚁相遇的情况,速度一样,又不分哪只蚂蚁,所以我们可以把他们看成直接穿过去了也未尝不可,那么每只蚂蚁就是独立的了。所以想求出最长时间,求蚂蚁到竿子端点的最大距离不就得了,就让他走最长的路。再遍历一次求出最长时间就可以了。

代码:

#include <stdio.h>

#define MAX 100010

int min(int x,int y)

{

if(x>y) return y;

else if(x<y) return x;

else if(x=y) return x;

}

int max(int x,int y)

{

if(x>y) return x;

else if(x<y) return y;

else if(x=y) return y;

}

int main ()

{

int t,l,n;

scanf("%d",&t);

while(t--)

{

int x[MAX]={0};

scanf("%d %d",&l,&n);

for(int i=0;i<n;i++) scanf("%d",&x[i]);

int minT = 0;

for(int i=0;i<n;i++) minT = max(minT,min(x[i],l-x[i]));

int maxT = 0;

for(int i=0;i<n;i++) maxT = max(maxT,max(x[i],l-x[i]));

printf("%d %d\n",minT,maxT);

}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 内容概要 《计算机试卷1》是一份综合性的计算机基础和应用测试卷,涵盖了计算机硬件、软件、操作系统、网络、多媒体技术等多个领域的知识点。试卷包括单选题和操作应用两大类,单选题部分测试学生对计算机基础知识的掌握,操作应用部分则评估学生对计算机应用软件的实际操作能力。 ### 适用人群 本试卷适用于: - 计算机专业或信息技术相关专业的学生,用于课程学习或考试复习。 - 准备计算机等级考试或职业资格认证的人士,作为实战演练材料。 - 对计算机操作有兴趣的自学者,用于提升个人计算机应用技能。 - 计算机基础教育工作者,作为教学资源或出题参考。 ### 使用场景及目标 1. **学习评估**:作为学校或教育机构对学生计算机基础知识和应用技能的评估工具。 2. **自学测试**:供个人自学者检验自己对计算机知识的掌握程度和操作熟练度。 3. **职业发展**:帮助职场人士通过实际操作练习,提升计算机应用能力,增强工作竞争力。 4. **教学资源**:教师可以用于课堂教学,作为教学内容的补充或学生的课后练习。 5. **竞赛准备**:适合准备计算机相关竞赛的学生,作为强化训练和技能检测的材料。 试卷的目标是通过系统性的题目设计,帮助学生全面复习和巩固计算机基础知识,同时通过实际操作题目,提高学生解决实际问题的能力。通过本试卷的学习与练习,学生将能够更加深入地理解计算机的工作原理,掌握常用软件的使用方法,为未来的学术或职业生涯打下坚实的基础。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值