HDOJ 2222 Keywords Search

Keywords Search

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 45283    Accepted Submission(s): 14351


Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
 

Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
 

Output
Print how many keywords are contained in the description.
 

Sample Input
  
  
1 5 she he say shr her yasherhs
 

Sample Output
  
  
3
 

Author
Wiskey

    AC自动机水题, 不做过多解释, 重要的是模板, 构建fail指针的时候稍微注意几个地方, 就OK了, 代码简洁又高效!


#include <cstdio>
#include <cstring>
#include <queue>

const int N = 500010;
using namespace std;

struct node{
	int next[N][26], cnt[N], fail[N];
	int root, total;

	int new_node() {
		for (int i = 0; i < 26; ++i)
			next[total][i] = -1;
		cnt[total] = 0;
		return total++;
	}

	void init() {
		total = 0;
		root = new_node();
	}

	void insert(char *str) {
		int cur = root;
		while (*str) {
			int idx = *str - 'a';
			if (next[cur][idx] == -1)
				next[cur][idx] = new_node();
			cur = next[cur][idx];
			++str;
		}
		++cnt[cur];
	}

	void build() {
		queue<int> q;
		fail[root] = -1;
		q.push(root);

		while (!q.empty()) {
			int cur = q.front();
			q.pop();

			for (int i = 0; i < 26; ++i) {
				if (next[cur][i] != -1) {
					int tmp = fail[cur];
					while (tmp != -1 && next[tmp][i] == -1)
						tmp = fail[tmp];
					fail[next[cur][i]] = tmp == -1 ? root : next[tmp][i];
					q.push(next[cur][i]);
				}
			}
		}
	}

	int query(char *str) {
		int cur = root;
		int ans = 0;

		while (*str) {
			int idx = *str - 'a';

			while (cur != -1 && next[cur][idx] == -1)
				cur = fail[cur];

			cur = cur == -1 ? root : next[cur][idx];
			int tmp = cur;
			while (tmp != -1 && cnt[tmp] != -1) {
				ans += cnt[tmp];
				cnt[tmp] = -1;
				tmp = fail[tmp];
			}

			++str;
		}

		return ans;
	}

}tree;

int main() {
	int T;
	scanf("%d", &T);
	char str[N << 1];

	while (T--) {
		char tmp[100];
		int n;
		scanf("%d", &n);
		tree.init();

		while (n--) {
			scanf("%s", tmp);
			tree.insert(tmp);
		}

		tree.build();
		scanf("%s", str);

		printf("%d\n", tree.query(str));
	}

	return 0;
}


                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值