POJ 2255Tree Recovery 二叉树重建(根据前序遍历和中序遍历写出后序遍历)

Tree Recovery
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13064 Accepted: 8147

Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
This is an example of one of her creations: 
                                               D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
However, doing the reconstruction by hand, soon turned out to be tedious. 
So now she asks you to write a program that does the job for her! 

Input

The input will contain one or more test cases. 
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
Input is terminated by end of file. 

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB

题解: 先序遍历的第一个字符就是二叉树中的根, 因此我们可以在中序遍历中找到这个字符,就知道这棵二叉树的左右子树了,然后递归即可.

另外,我们完全可以不用把得到的后序遍历的二叉树存到数组当中,在递归程序中打印即可.


#include <cstdio>
#include <cstring>

const int N = 40;

void rebuild(int len, char* s1, char* s2, char* str) {
	if (len <= 0) return ;
	int tmp;
	for (tmp = 0; s2[tmp] != s1[0]; ++tmp) {};
	rebuild(tmp, s1 + 1, s2, str);
	rebuild(len - tmp - 1, s1 + 1 + tmp, s2 + 1 + tmp, str + tmp);
	str[len - 1] = s1[0];
}

int main() {
	char s1[N], s2[N], str[N];

	while (~scanf("%s%s", s1, s2)) {
		rebuild(strlen(s1), s1, s2, str);
		str[strlen(s1)] = 0;
		printf("%s\n", str);
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值