HDU Triangle 2016中国大学生程序设计竞赛(长春)-重现赛

Triangle
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
Mr. Frog has n sticks, whose lengths are 1,2, 3⋯n respectively. Wallice is a bad man, so he does not want Mr. Frog to form a triangle with three of the sticks here. He decides to steal some sticks! Output the minimal number of sticks he should steal so that Mr. Frog cannot form a triangle with
any three of the remaining sticks.


Input
The first line contains only one integer T (T≤20), which indicates the number of test cases.

For each test case, there is only one line describing the given integer n (1≤n≤20).


Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of sticks Wallice should steal.


Sample Input

3
4
5
6



Sample Output

Case #1: 1
Case #2: 1
Case #3: 2

水题 穷举即可

#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<string>
#include<vector>
#include<deque>
#include<queue>
#include<algorithm>
#include<set>
#include<map>
#include<stack>
#include<time.h>
#include<math.h>
#include<list>
#include<cstring>
#include<fstream>
//#include<memory.h>
using namespace std;
#define ll long long
#define ull unsigned long long
#define pii pair<int,int>
#define INF 1000000007
#define pll pair<ll,ll>
#define pid pair<int,double>
//#define CHECK_TIME

vector<int>vec;

bool check(){
    for(int i=0;i<vec.size();++i)
        for(int j=i+1;j<vec.size();++j)
            for(int k=j+1;k<vec.size();++k){
                if((vec[i]+vec[j]>vec[k])&&(vec[i]+vec[k]>vec[j])&&(vec[j]+vec[k]>vec[i]))
                    return true;
            }
    return false;
}

int main()
{
    //freopen("/home/lu/文档/r.txt","r",stdin);
    //freopen("/home/lu/文档/w.txt","w",stdout);
    int t,n;
    cin>>t;
    for(int tt=1;tt<=t;++tt){
        cin>>n;
        int ans=INF;
        int k=1<<n;
        for(int i=0;i<k;++i){
            vec.clear();
            int tmp=i;
            for(int j=1;tmp>0;++j){
                if(tmp&1)
                    vec.push_back(j);
                tmp>>=1;
            }
            if(!check())
                ans=min(ans,n-(int)vec.size());
        }
        cout<<"Case #"<<tt<<": "<<ans<<endl;
        //cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值