1002 A+B for Polynomials (25分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

 

Sample Output:

3 2 1.5 1 2.9 0 3.2

1、理解题意

给出两个多项式A和B,输出A+B,输出格式如题目样例,输出结末尾不需要多余空格,系数精确到小数点后一位。

2、解题思路

(1)建立数组A,下标表示指数,对应值为系数,初始值均为0,对每个多项式,先给出非零项个数K,按照指数从大到小的顺序依次输出“指数 系数”;

(2)每输入一个多项式,A当中的对应指数就加上刚输入的系数,加完后,A中的非零元素及其下标即为结果的系数和下标。

#include<cstdio>
double A[1010]={0};
int main(){
	int k;
	int n;
	double a;
	scanf("%d",&k);
	for(int i=0;i<k;i++){
		scanf("%d %lf",&n,&a);
		A[n] +=a;
	}
	scanf("%d",&k);
	for(int i=0;i<k;i++){
		scanf("%d %lf",&n,&a);
		A[n] +=a;		
	}
	int count=0;
	for(int i=0;i<1010;i++){
		if(A[i]!=0){
			count++;
		}
	}
	printf("%d",count);
	for(int i=1009;i>=0;i--){
		if(A[i]!=0){
			printf(" %d %.1f",i,A[i]);
		}
	}
	return 0;
}

3、总结

(1)如果使用两个数组A和B分别存储两个多项式,再将结果存储到数组C中会发生段错误,即运行内存不够,所以不能使用暴力解决。

(2)double类型的输入格式符为“%lf”。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值